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B Trademarks

Microsoft, Windows, Windows 8, Windows 7, Windows Vista and Windows XP are registered
trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

B Abbreviations
Throughout this document the following abbreviations are used in text.
e Microsoft Windows 8 is abbreviated as “Windows 8”
e Microsoft Windows 7 is abbreviated as “Windows 7”

e Microsoft Windows Vista is abbreviated as “Windows Vista”
e Microsoft Windows XP is abbreviated as “Windows XP”

B May we request

Thank you for understanding the following points.

Copying this guide or any part of this guide without permission is strictly forbidden.

The specifications for this printer as well as the software provided with the printer are
subject to change without prior notice.

We strive to ensure accuracy of information in this guide, but if you notice errors or
omissions, please contact us.

e We can accept no responsibility for loss or damages resulting from the use of this
software.



SOFTWARE LICENSE AGREEMENT

Note: Please read the following software license agreement (to be referred to as the "Agreement") carefully.
This Agreement is made between Nisca Corporation (to be referred to as "Nisca™) and the user for use of
software (to be referred to as the "Software,” and to include manuals, printed matter and so forth in addition
to this Agreement) provided with this Agreement by the user for the purpose of using the applicable printer
made by Nisca (to be referred to as the "Printer™).

The user shall be presumed to have agreed to this Agreement either by taking an action that indicates
"Consent™ to the terms of the Agreement or by using the Software. The user shall not be permitted to use
the Software in the case of not agreeing with the Agreement.

1. License

(1). Nisca shall grant the user non-exclusive license to install the Software into a single computer and use
such installed Software on such single computer at a time for the purpose of using the Printer. The
user may not use the Software on plural computers at a time or on a network.

(2). The user shall be permitted to make one reproduction of the Software as a backup for using the
Software on the basis of clause (1) above.

(3). With the exception of that stipulated in clauses (1) and (2) above, any and all of intellectual property
rights of Nisca or licensors of Nisca, whether express or implied, shall not be transferred or licensed to
the user by this Agreement.

2. Restrictions on Use

(1). The user shall not allow the Software to be used by a third party by sub-licensing, transfer, sales,
distribution, lease, loan or any other method.

(2). The user shall not be permitted to revise, modify, decompile, disassemble or perform any other form
of reverse engineering on all or any portion of the Software. The user shall also not allow such actions
to be taken by a third party.

3. Title
Title and ownership relating to the Software shall be retained by Nisca or a licensor of Nisca depending
on their contents.

4. Copyright Markings
The user shall not alter, remove or delete any copyright markings of Nisca or a licensor of Nisca
contained in the Software.

5. Disclaimer and Exemption of Warranties

(1). The Software is licensed "as is". Nisca, affiliates of Nisca (exclude Nisca, to be referred to as
"Affiliates™) and their agents or vendors shall not make any warranty, whether express or implied,
including warranty of product feasibility or suitably to a specific purpose, with respect to the Software.

(2). Nisca, Affiliates and their agents or vendors shall not be liable, as recognized by applicable laws, for
any damages incurred due to the use or inability to use the Software (referring to all damages,
including, but not limited to, lost profit and other derivative or incidental damages). This shall apply
similarly even if Nisca, Affiliates and their agents or vendors were informed of the possibility of said
damages.

(3). Nisca, Affiliates and their agents or vendors shall not bear any liability regarding any and all disputes
arising between the user and a third party caused by or related to use of the Software.

6. Export
The user shall not export, either directly or indirectly, all or any portion of the Software without
obtaining the required approval from the Japanese government or related foreign governments.

7. Term of Agreement



(1). This Agreement shall come into effect at the time the user has taken an action that indicates "Consent"
to the terms of the Agreement or at the time the Software has been used, and shall remain in effect
until terminated in accordance with clause (2) or (3) below.

(2). The user shall be able to terminate this Agreement by discarding and erasing the Software and all of
its reproductions.

(3). This Agreement shall terminate immediately when the user has violated any of the terms of the
Agreement.

(4). If the Agreement has been terminated as result of clause (3) above, the user shall promptly discard or
erase the Software and all of its reproductions.

8. U.S. Government Restricted Rights Notice
The Software is a "commercial item,” as that term is defined at 48 C.F.R. 2.101 (Oct. 1995), consisting
of "commercial computer software™ and “commercial computer software documentation,” as such items
are used in 48 C.F.R. 12.212 (Sept. 1995). Consistent with 48 C.F.R. 12.212 and 48 C.F.R. 227.7202-1
through 227.7202-4 (June 1995), all U.S. Government End Users shall acquire the Software with only
those rights set forth herein. Manufacturer is NISCA CORPORATION/430-1 Kobayashi, Fujikawa-cho,
Minamikoma-gun, Yamanashi 400-0593, Japan. The term "the Software" used in this clause refers to
and indicates the "Software" defined in this Agreement.

9. Separable Agreement
In the case it has been determined that a portion of any of the terms of this Agreement become invalid by
law, the other terms of the Agreement shall remain completely in effect.

Nisca Corporation
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Introduction

Introduction

This manual contains descriptions of operating instructions for the Application software “M-1 Pro
IV PC” and the printer driver for “M-1 Pro IV” printer.
Please read this manual carefully to ensure correct operation.

This manual has been written with the assumption that users have knowledge of basic Windows
operations and functions. We recommend that users familiarize themselves with the Windows
environment before using M-1 Pro IV PC. For details about Windows terminology or operations
such as ‘Open’, refer to the documentation provided with Windows.

B Features of the PC Connection Kit

Following functions are available with the PC Connection Kit.
« "PC Connection Kit" consists of a software CD and a USB cable.

Data which is made on a computer can be transmitted to the M-1 ProlV printer. It will be
able to input data more quickly and easily.

A number of data files can be saved in a computer.

CSV form data can be used.

Print by the remote operation is possible.

USB2.0
A connector — B connector

B Screens Appearing in This Manual

e This manual provides descriptions using the screens displayed under Windows 7.
Basically, the screen contents and operation methods of Windows 7 are true of Windows 8,
Windows Vista and Windows XP. If they are different, descriptions will be provided
separately for individual operating systems.

e Buttons displayed on the screen are enclosed in [ ].
Example: [OK]

B Explanation of Symbols

The meanings of the symbols that are used in this manual are explained below.

@ important An important notice or restriction to be followed to prevent troubles due to
improper operation is written. Be sure to read it.

Supplementary information is provided to facilitate operation.




System Requirements

System Requirements

The hardware and software items listed below are required for using M-1 Pro IV PC.
B Compatible operating systems

Windows 8 (32bit/64bit) English

Windows 7 Service Pack 1 (32bit/64bit) English
Windows Vista Service Pack 2 (32bit) English
Windows XP Service Pack 3 (32bit) English

«» Be sure to log on as a member of Administrators when starting up.

B Computer
A computer that supports any of the above operating systems.

B Monitor and video driver

A Monitor capable of 1024 x 768 dots resolution and 256 color display or higher.
1280 x 1024 recommended.

+» When using an 1024 x 768 dot monitor, set the display font size to “Small Fonts”.

B In case of using the "PC Connection Kit for M-1 Prolll"

In case the application software and the printer driver for "M-1Prolll" printer have already been
installed, it is necessary to uninstall both of them in order at first.

(1) How to uninstall the application - Please uninstall it referring to the procedure as is explained
in "Uninstalling the Software (P.11)".

(2) How to uninstall the printer driver - It doesn't have an uninstaller program for the printer driver.
During the installation of the application software and the printer driver for "M-1ProlV" printer,
a message appears to ask whether to uninstall the printer driver for "M-1Prolll" printer or not.
Then please uninstall the printer driver for an M-1Prolll printer according to the message.

You can print with "M-1Prolll" printer by the use of the application software for "M-1ProlV"
printer.



Installing

1. Installing

1.1 Installing M-1 Pro IV PC and the Printer Driver

Install M-1 Pro IV PC and the printer driver for the M-1 Pro IV into your computer.

+» Close all applications before installing the software.
«» Be sure to log on as a member of Administrators when starting up.

+» Windows 8 / Windows 7 / Windows Vista / Windows XP allows multiple users to use one
computer at the same time. However, only one user can log on to the computer when making
settings.

+« Do not make the printer connected with the computer till installation is completed.

« This CD-ROM contains programs for both 64bit use and 32bit. Please confirm your Computer
before the use.

@ important

Do not switch off the computer till installation is completed. Installation may become impossible.

1 Have ready the installation CD-ROM that contains the software.
2 Turn on your computer and start Windows.
3 Insert the CD-ROM to install the software into your CD-ROM drive.

o If the CD-ROM does not start automatically, double-click the CD-ROM drive icon,
and then double-click the [Run Setup.exe] file in the [APP] folder.

e When the AutoPlay screen appears, click [Setup.exe].

=31 DVD Drive (D) M-1Pro4PC

[T Ahways do this for software and games:

Install or run program from your media

v Run Setup.exe
Publisher not specified

General opticns

Open folder to view files

using Windows Explorer

View more AutoPlay options in Control Panel




Installing

@ Ll When the User Account Control dialog box appears, click the [Yes].
(G User Account Contro LJ

Do you want to allow the following program from an
unknown publisher to make changes to this computer?

Program name:
Publisher:
File origin:

(%) Show details

Setup.exe
Unknown
CD/DVD drive

[ Yes ] l No

Change when these notifications appear

Install the M-1Pro IV PC.

(1) Click the [OK].

Cable LD. Printer Setup

@ Start the setup of the tube printer. Start the installation of the tube
W' printer application first. After that the installation of the printer driver
will be started.

(2) Click the [Next].

M-1PrcIVPC - InstallShield Wizard

Welcome to the InstallShield Wizard for
M-1Prol¥PC application

The InztallS hield ‘wizard will ingtall b-1ProlWPC on pour
computer. To continue, click Nest.

< Back ‘ Mest » ’ Cancel



Installing

(3) Read the License Agreement, select “I accept the terms of the license agreement”
and then click the [Next].

M-1ProlVPC - InstallShield Wizal

License Agreement
Please iead the following license agreement carefully.

Software License Agreement

Note: Please read the following software license agreement (fo be referred
to as the "Agreement") carefully. This Agreement is made between Nisca
Corporation (to be referred to as "Nisca") and the user for use of software
(to be referred to as the "Software." and to include manuals, printed
matter and so forth in addition to this Agreement) provided with this
Agreement by the user for the purpose of using the applicable printer
made by Nisca (to be referred to as the "Printer").

@ accept the teims of the license agreement

(1 ] do nat accept the terms of the license agresment

InstallShield

[ < Back I Mext > l[ Cancel ]

e To print the License Agreement out from a default printer, click the [Print].

(4) Specify the destination for installation and then click the [Next].

M-1ProlVPC - InstallShield Wizard x|

Choose Destination Location
Select folder where setup will ingtall files.

G Irstall M-1PralVPC to
4 \Misca Corporationh-1ProlvPC

[ < Back I Mext » l[ Cancel ]

e Toinstall the software in the folder displayed, click the [Next].
e To install the software in a different folder, click the [Change] and specify a folder.



Installing

(5) Click the [Install].

M-1PralVPC - InstallShield Wizard ==

Ready to Install the Program

The wizard is ready to begin installation

Click Install ta begin the installation
IF wou want ta review or change any of pour installation settings, click Back. Click Cancel to exit
the: wizard.
IristallShield
¢ Back I Inztall I [ Cancel

(6) Click the [Finish].

M-1PralVPC - InstallShield Wizard

InstallShield Wizard Complete

The InztallShield Wizard has successfully installed
M-1PralVPC. Click Finish to exit the: wizard

< Back Cancel
This completes the M-1Pro IV PC installation.
Next, Install the Printer Driver.
Install the Printer Driver.
(1) Click the [Next].
M-1ProlV Printer Driver - InstallShield Wizard u

Welcome to the InstallShield Wizard for
M-1Prol¥ Printer Driver

The InstallShield Wizard will ingtall M-1Pral\’ Printer Driver
oh your computer. To continue, click Mext.




and then click the [Next].

M-1PralV Printer Driver - InstallShield Wizard

License Agreement
Please read the fallowing license agreement carefully.

Software License Agreement -

Note: Please read the following software license agreement (to be referred
to as the "Agreement") carefully. This Agreement is made between Nisca
Corporation (fo be referred to as "Nisca") and the user for use of software
(to be referred to as the "Software." and to include manuals. printed
matter and so forth i addition to this Agreement) provided with this
Agreement by the user for the purpose of using the applicable printer
made by Nisca (to be referred to as the "Printer").

@)1 accept the bermes of the licenss agreement

() | do not accept the terms of the license agreement

[ < Back l Mext » l[ Cancel ]

Installing

(2) Read the License Agreement, select “I accept the terms of the license agreement”

To print the License Agreement out from a default printer, click the [Print].

(3) Click the [Install].

-
M-1PralV Printer Driver - InstallShield Wizard

Check the connection

If the device has been already connected ta the PC, pleaze turn it off or disconnect once:
Then click [Install] to start the installation.

< Back I Install I[ Cancel

(4) Click the [OK].

M-1ProlV Printer Driver - InstallShield Wizard (S|

Restart the PC, then connect the USE cable to the device and turn it on.




Installing

(5) Select “Yes. Restart computer now” and then click the [Finish].

M-1PralV Printer Driver - InstallShield Wizard

IngtallShield Wizard Complete

The InztallShield Wizard has successfully installed -1Pol
Printer Driver. Before you can use the program, you must
Testart pour computer.

() Mo, | will restart my computer later.

Click Finish to complete setup.

< Back Cancel

After restart computer and then press the [PC Conn] key on the printer.
This completes the Printer Driver installation.

In case the installation is not completed even by pressing the [PC conn] key after
rebooting the PC, please retry to switch on the printer and press the [PC conn]

key once again.



¢

¢

If the following screen appears, perform the following operation:

Click the “Install this driver software anyway”.

< Don'tinstall this driver software

You should check your manufacturer's website for updated driver software
for your device.

= Install this driver software anyway

Only install driver software obtained from your manufacturer's website or
disc. Unsigned software from other sources may harm your computer or steal
information.

e W,

i:v_;j See details

Windows 8

Click the [Install]

Would you like to install this device software?

~ Mame: Misca Corporation Printers
ﬂ’ Publisher: Misca Corporation,

[ Abways trust software from "Nisca Corporation.”. I Install || Don't Install

@ You should only install driver software from publishers you trust. How can | decide
which device software is safe to install?

Windows Vista

Click the [Continue]

T
User Account Control
4‘7
\F Windows needs your permission to continue.

If you started this action,continue.

] Printer driver software installation
Microsoft Windows

| Details [ Continue ” Cancel

User Account Control helps stop unauthorized changes to your computer.

Installing
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Installing

Windows XP
When the following screen appears, click the [Continue Anyway].

Software Installation

] E The zoftware you are instaling has not passed Windows Logo
L) testing to wenfy itz compatibility with 'Windows XP. [Tel me why
thiz testing is impartat, )

Continuing your installation of this software may impair
or destabilize the comect operation of your system
either immediately or in the future. Microzoft strongly
recommends that pou stop this installation now and
contact the zoftware vendor for software that has
paszed Windows Logo testing.

"E'.Eontinue Appaay ; [ STOP Installation

Hardware Installation

| E The software you are ingtalling for this hardware:
L

Printers

haz nat passed Windows Logo testing ta verify its compatibility

with Windows P, [Tell me why this testing is impartant. |

Continuing your installation of this software may impair
or destabilize the comect operation of your system
either immediately or in the future. Microsoft strongly
recommends that pou stop this installation now and
contact the hardware vendor for zoftware that has
passed Windows Logo testing.

[ Continue Arpway

STOF Installation

When printer driver of the M-1 Pro Ill is already installed, the next screen is
displayed. Click the [Yes].

Please uninstall the application software for "M-1Prolll" printer according to the
same procedure as is explained in "Uninstalling the Software (P.11)".

M-1ProlV Printer Driver - InstallShield Wizard r [

Because 'M-1Prelll' is already installed, installation of this printer cannet continue,
Do you want to remoeve 'M-1Proll' te install this printer?

@ important

With the use of the M-1 Pro IV application and printer driver, the M-1 Pro Il printer
operation is possible. Do not install the application and printer driver for M-1 Pro Il after
those for M-1 Pro 1V is installed.

When the application and printer driver for M-1 Pro Il is installed, please install those for
M-1 Pro IV again.

10



Installing

1.2 Uninstalling the Software

To uninstall the “M-1 Pro IV PC” and “M-1 ProlV printer driver”, go through the following
procedure:

@l important

When you perform uninstallation, turn off the printer and pull off the USB cable in advance.

Do not switch off the computer till uninstallation is completed. Uninstallation may become
impossible.

<Windows 8>

(1) Select [Control Panel] from the Windows [Settings].
The "Control Panel" folder will be displayed.

(2) Click on [Programs].

(3) Click on [Programs and Functions].

(4) Select [M-1 Pro IV PC] from the list of the programs, and then click the [Uninstall].

(5) When the confirmation message appears, click the [OK].

(6) Select [M-1 Pro IV Printer driver] from the list of the programs, and then click the
[Uninstall].

(7) When the confirmation message appears, click the [OK].
(When the User Account Control dialog box appears, click the [Continue].)

<Windows 7 / Windows Vista>
(2) Click the ﬁ button (Start), select [Control Panel] — [Programs], and then click

[Uninstall a program].
(2) Select [M-1 Pro IV PC] from the list of the programs, and then click the [Uninstall].
(3) When the confirmation message appears, click the [OK].
(4) Select [M-1 Pro IV Printer driver] from the list of the programs, and then click the
[Uninstall].
(5) When the confirmation message appears, click the [OK].
(When the User Account Control dialog box appears, click the [Continue].)

<Windows XP>
(2) Click the [Start], and then select [Control Panel] — [Add or Remove Programs].
(2) Select [M-1 Pro IV PC] from the list of the programs, and then click the [Remove].
(3) When the confirmation message appeatrs, click the [OK].
(4) Select [M-1 Pro IV Printer driver] from the list of the programs, and then click the
[Removel].
(5) When the confirmation message appears, click the [OK].

11



Starting M-1 Pro IV PC

2. Starting M-1 Pro IV PC

2.1 Starting

You can start M-1 Pro IV PC by one of the following methods:

e Double-click the M-1Pro IV PC icon on the desktop.
¢ Windows 8
Select [All Programs] from the Windows [Start] menu, and then select [M-1Pro IV
PC] - [M-1Pro IV PC].
¢ Windows 7 / Vista

Click the button (Start), and then select [All Programs] — [M-1Pro IV PC] —
[M-1Pro IV PC].

¢ Windows XP

Click the [Start], and then select [All Programs] or [Programs] — [M-1Pro IV PC] —
[M-1Pro IV PC].

The main screen appears when you start M-1 Pro IV PC.

File(F) Edit(E) View(V) Remote(R) Help(H)

DEd|&]* 2R nEEEEE

Terminal I.D.
printing area

5 5 Allline: . -
Orientation Frame SetLength Alignment s Character Size Character Space Lines

| Hor fHor char ‘ None | Automatic ‘ Normal | Centered | off | 3 mm Morm Narrow 1Lline

Selection  Page 1st Line 2nd Line 3rd Line Continuous o

1

Press [F1] to display the help menu.

12



Starting M-1 Pro IV PC

When started an application for the first time, select printer screen is displayed.
Select " M-1 Pro IV ", and please click the [OK].

Select printer

Set a printer to use.

Acquire printer information after verifying the PC connection with the printer.
At the time of changing & printer to use, open this DIALOG from a menu and
setit.

Select printer ’M—lProI'«' v ]

The setting of the device type
(@) M-1ProIV (Terminal I.D. printing area adjustment function)

() M-1ProlII (Mo Terminal I.D. printing area adjustment function)
Automatic acquisition

OK ][ Cancel l

e Within the [Select printer] box, an installed printer driver for a cable ID printer is
displayed.

e At the [The setting of the device type], please choose a printer to use between M-
1ProlV and M-1Prolll.

e You can reach this screen by operation of [Select printer] in the [File] menu.

You cannot select [select printer] when start an application before the installation
of the printer driver is completed. Complete installation first.

Set a printer to use,

Acquire printer information after verifying the PC connection with the printer.
At the time of changing a printer to use, open this DIALOG from a menu and
setit.

The setting of the device type

(@) M-1Prol¥ (Terminal I.D, printing area adjustment function):

(©) M-1ProllI {No Terminal 1.D. printing area adjustment function)

Automatic acquisition

2.2 Shutting Down

You can shut down M-1 Pro IV PC by one of the following methods:

e Click [Exit] in the [File] menu.
e Click the button upper right of the main screen.

+*» In case the setting is changed while data is being edited, a message appears to
ask whether to save the data or not.

T

L Save changes to data.md3 7

| [ cancel

13



Screen Structure

3. Screen Structure

This section describes details of the tool buttons and menus contained in M-1 Pro IV PC.

3.1 Main Screen

This appears when you start M-1 Pro IV PC.

Menu Bar

Toolbar

Style Settings /Data
Display Area

File(F) Edit(E) View(V) Remote(R) Help(H)
D]+ B mn E%E.EL N
\4
- Terminal I.D. " Allline: -
Orientation Frame Setlength printing area Alignment e Character Size Character Space Lines ‘-
‘ Hor Hor char ‘ None | Automatic ‘ Normal Centered | Off | 3 mm Norm Marrow ‘ 1line
Selection  Page 1st Line 2nd Line 3rd Line Continuous .

1

Press [F1] to display the help menu.

——  Setting button

—— Data List

\— Status Bar

F.g.1 Main screen

14



Data List

Screen Structure

This is a list of files currently being edited.

Toolbar

The toolbar contains the following buttons.

Tool button

Description

[

Creates a new data list.

Does the same thing as selecting [New] from the [File] menu.

+» In case the setting is changed while data is being edited, a message
appears to ask whether to save the data or not.

Opens an existing file or CSV file and loads the data.

Does the same thing as selecting [Open] from the [File] menu.

< In case the setting is changed while data is being edited, a message
appears to ask whether to save the data or not.

+ If you attempt to open an existing file with the old format (.mtd / .md2), a
message may appear to indicate that it has been replaced with a file with
the new format (.md3).

Saves the data you are editing in an existing file.
Does the same thing as selecting [Save] from the [File] menu.

Sends the data you are editing to the M-1 Pro IV.
Does the same thing as selecting [Send] from the [File] menu.

=W K

Sets a numbering and adds numbering data to the specified pages.
Does the same thing as selecting [Numbering] from the [Edit] menu.

-

Inserts a blank page in front of the cursor page.
Does the same thing as selecting [Page Insert] from the [Edit] menu.

MIFs | lFA

a

Deletes the cursor page.
Does the same thing as selecting [Page Delete] from the [Edit] menu.

i ||

Cuts the specified page and pastes it to the clipboard.
Does the same thing as selecting [Page Cut] from the [Edit] menu.

Copies the contents of the specified page to the clipboard.
Does the same thing as selecting [Page Copy] from the [Edit] menu.

7
INFA

Pastes the contents of the clipboard by inserting it in front of the specified

page.
Does the same thing as selecting [Page Paste] from the [Edit] menu.

Style Settings /Data Display Area

This area displays current format settings. To change the format settings, click the

setting...  |button.

!

For details about settings, refer to “4.5 Format Settings”(P.32).

15



Screen Structure

Menu Bar

The Menu bar contains the following menus.

|FiIEI:FJ Edit(E) View(V) Remote(R) Help(H)

B [File] menu

Mew(M) Ctrl+MN
Open(0]... Ctrl+0Q
Add(L)...

Savels) Ctrl+5
Save As(A)... Ctrl+ 4
Select printer(E}...

Send data, and Save file / Print(P]... Ctrl+P

Printer data backup(D]...

Exit ()
Menu item Description
New (N) Creates a new data list.
There is also the D button that performs this function.
+ In case the setting is changed while data is being edited, a
message appears to ask whether to save the data or not.
Open (O) Opens an existing file or CSV file and loads the data.
There is also the ﬁ button that performs this function.
< In case the setting is changed while data is being edited, a
message appears to ask whether to save the data or not.
+ If you attempt to open an existing file with the old format (.mtd
/.md2), a message may appear to indicate that it has been
replaced with a file with the new format (.md3).
Add (L) Opens another file and adds the data to the data you are editing.
Save (S) Saves the data you are editing in an existing file.
There is also the E button that performs this function.
Save As (A) Saves the data you are editing in a new file with a name that you

assign.

Select printer (E)

Select a printer to use.

Send data ,and Save
file/Print. (P)

Sends the data you are editing to the M-1 Pro IV.
There is also the & button that performs this function.

Printer data backup (D)

Saves the backup data of the files stored in the printer to the
computer, or writes backup data to the printer.

Exit (X)

Shuts down M-1 Pro IV PC.
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Screen Structure

B [Edit] menu

Page Cut(k)
Page Copy(Q)
Page Paste(L)
Page Insert(I)
Page Delete(R)
Format Setting(s) » Page Setting(P)
Default Setting (D)
Menu item Description
Cut (T) Cuts the specified data and pastes it to the clipboard.
Copy (C) Copies the selected contents to the clipboard.
Paste (P) Pastes the contents of the clipboard.
Delete (D) Deletes the selected part.
Numbering (N) Sets a numbering and adds numbering data to the
specified pages.
There is also the Hl]_ button that performs this function.
Page Cut (K) Cuts the specified page and pastes it to the clipboard.
There is also the !E button that performs this function.
Page Copy (O) Copies the contents of the specified page to the
clipboard.
There is also the I;E button that performs this function.
Page Paste (L) Pastes the contents of the clipboard by inserting it in
front of the specified page.
There is also the IE'E button that performs this function.
Page Insert (1) Inserts a blank page in front of the cursor page.
There is also the ,E button that performs this function.
Page Delete (R) Deletes the cursor page.
There is also the ‘E button that performs this function.
F ) Page Setting (P) Changes the format settings for the cursor page.
ormal
Setting (S) Default Setting (D) | Sets t_he defgult fqrmat to be used when creating new
data lists or inserting pages.
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Screen Structure

B [View] menu

v Data Toolbar(l) |
|

v Send Toolbar(2)
v Edit Teclbar(3)
v Status Bar(%) |
Menu item Description
Data Toolbar (1) Shows or hides the data toolbar.
Send Toolbar (2) Shows or hides the send toolbar.
Edit Toolbar (3) Shows or hides the edit toolbar
Status Bar (S) Shows or hides the status bar.

B [Remote] menu

Print{P]... |
Save file(S)... i
Menu item Description
Start Print (P) Sends a print command to the M-1 Pro IV.
Save Data (S) Sends a save data command to the M-1 Pro IV.

B [Help] menu

Help F1 |
About(A)... i
Menu item Description
Help F1 Displays M-1 Pro IV PC help.
About (A) Displays M-1 Pro IV PC version information.
Status Bar

Displays the current status of the M-1 Pro IV PC.
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Operating

4. Operating M-1 Pro IV PC

M-1 Pro IV PC

4.1 File Types

With M-1 Pro IV PC, you can load the following file types into the data list.

e Original data files (.md3)
e CSV files (Comma separated text files)

To load data into the data list, files must meet the following conditions:

1stline:  First line of character data
2nd line:  Second line of character data
3rd line:  Third line of character data
4th line:  Number of continued printing

«»+ Data from and including the 5th line is ignored.

(E.g.1) Loading CSV data into M-1 Pro IV PC

(Data list)
A, 123, 456, 1, A, 789+ = » — 1st page
B, 123, 456, 2, B, 789+ « « — 2nd page
C, 123, 456, 3, C, 789+« = « —F— 3rdpage
—
Invalid data
Lines1st 2nd  3rd Continuous
(Data list)
(E.g.2) CSV data from E.g.1 loaded into the data list.
Page 1st line 2nd line 3rd line Continuous
1 A 123 456 1
2 B 123 456 2
3 C 123 456 3
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(E.g.3) data list from E.g.2 printed a list of data.

Operating M-1 Pro IV PC

A B B C C C

123 | 123 | 123 | 123 | 123 123

456 | 456 | 456 | 456 | 456 | 456
—_—\ /S ~ ~

L Page 3:Continuous 3

Page 2:Continuous 2

Page 1:Continuous 1

«» If you select [1 Line] in [Lines], the first line of data in the CSV file is loaded, but
the second line and the third line are ignored.

+» The third line of data can be loaded only when [Character Size] is set to [1.3mm
Norml].
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4.2 Basic Operations

This section describes the methods for creating new data lists, creating data lists from existing
data and sending data to the M-1 Pro IV.

Creating a New Data List

1 Click [New] in the [File] menu or click the D button.

A new data list is created.
The format set in [Format Setting] — [Default Setting] in the [Edit] menu is used.

+ In case the setting is changed while data is being edited, a message appears to
ask whether to save the data or not.

M-1PralVPC A ===

l i Save changes to data.md3 7

[Yes]: Saves the data you are editing and creates a new data list.
If the file already has a name, it is overwritten.
If the file does not have a name, the Save As dialog box appears,
where you can give the file a name.

[No]: Creates a new data list without saving the data you are editing.
[Cancel]: Cancels the [New] command.
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Opening Existing Files

You can load your own original data files (.md3) or CSV files into the data list.

. . . . ~u
1 Click [Open] in the [File] menu or click the [ button.
The Open dialog box appears.
%= Open [
Laak in: | My Documents - @ ? - V
I= Name B Date modified
el &5 data 2011/08/12 15:58 !
Recent Places

Desktop

LiEraries
LY

Computer < m b
@ File name: - Open
T Files of type: [M—1 PralvPC File (F md3) ,] ﬂ]

2 Select an original data file (.md3) or CSV file, and then click the [Open].

The selected file is loaded and displayed in the data list.
The format set in [Format Setting] — [Default Setting] in the [Edit] menu is used.

+» In case the setting is changed while data is being edited, a message appears to
ask whether to save the data or not.

SR

L.\ Save changes to data.md3 7

[Yes]: Saves the data you are editing and creates a new data list.
If the file already has a name, it is overwritten. If the file does not
have a nhame, the Save As dialog box appears, where you can give
the file a name.

[No]: Opens the selected file without saving the data you are editing.
[Cancel]: Cancels file loading.
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«» If you attempt to open an existing file with the old format (.mtd / .md2), a
message may appear to indicate that it has been replaced with a file with the new
format (.md3).

e . ==

4 lf Older formatted data has been replaced by newly formatted data.

[OKT: The file with the new format (.md3) substitutes for the existing file
with the old format (.mtd / .md2) and then opens.

3 When you select a CSV file, the Read Format Selection dialog box appears.

For details about individual setting items, refer to “4.5 Format Settings”(P.32).

r B
Orientation [HoriHormar ']
Frame None -
Set Length (@ Automatic (") Spedfy
2.00 * | mm (2.00-150.00)

Terminal 1.D. printing area Mormial

Alignment Centered

All line centering off

Character Size ’3 mm MNorm -
Character Space

Continuous = (1-100)

[ Ok ] ’ Cancel

« If you select [1 Line] in [Lines], the first line of data in the CSV file is loaded, but
the second line and the third line are ignored.

+» The third line of data can be loaded only when [Character Size] is set to [1.3mm
Norm].
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Operating M-1 Pro IV PC

Loading Additional Data

You can add data to a specified position in the data list.

1
2

Select the file you want to add, and then click the [Open].
The Open dialog box appears.

Select the file you want to add, and then click the [Open].

The data in the selected file is added at the cursor position.

Saving Data Lists

B Overwriting when saving

1 Click [Save] in the [File] menu or click the n button.

The file you are editing is overwritten.

< If “Untitled” appears in the title bar, the Save As dialog box appears. For details
about saving the file, refer to “Saving a file with a new name” (P.25).

« If you attempt to open an existing file with the old format, it is replaced with the file
with the new format (.md3). Accordingly, selecting [Save] displays the Save As

dialog box. The file saved in the new format cannot be opened by the old version
of software.
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B Saving a file with a new name

1

Select [Save As] from the [File] menu.
The Save As dialog box appears.

Input the file name, specify the file type, and then click the [Save].
Select the file type from the following: The contents that are saved depend on the file

type.
[Original data files (.md3)]: Saves format settings and data list contents.

[CSV file]: Saves the first, second and third lines of character
data in the data list, and the numbering value.

e W
Sawe in: @Documents - @ _? = '

T Mame Date modified

el &5 data 2011/08/12 15:58
Recent Places

Libraries

LY

Computer <

@ File name: rik21 002

Bleiem ol Save az type: [M—1 Prol PG File (¢ md3) ,] Cancel

The data list is saved with the file name you assigned.

« If a file already exists with the same name as the one you input, a message
appears asking whether it is ok to overwrite the existing file.

- B
ST

l data.md3 already exists.
E Do you want to replace it?

L
[Yes]: The file is overwritten.
[No]: The file is not saved.
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4.3 Sending Data to the Printer

You can send data you create with M-1 Pro IV PC to the M-1 Pro IV.
This section also describes settings for saving and printing sent data.

Send data, and Save file / Print . ﬂ

Transfer Mode

() Add to internal memary.

i ) File Save after the send data.
|| save transmitted data.
File name
Folder Mo.
y,
Gm et A Print after the send data.
Print Media Label
Media Size 9 mm
Sets to Print | 1 | (1-10)

[—

Before sending data to the printer, connect the USB cable to the printer and the computer.

1 Connect the printer to the computer with the USB cable.

For how to connect with the USB cable, refer to “Connecting the Printer and
Computer” (P.36).
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2 Power the printer on. When the character input display appears, press the [PC Conn]
key on the printer.

[PC Conn] key
[ - |
(LI I Irrrrro m \I|W‘u‘
‘I‘F [ ] LTI
LI T I T T TIITOTITT ]
IR EEEEEEEEEES

CITITIT T T I

| T e~
| | I E §i 03]

I

= n&> MM PC Connect
# Standby. ..
HAH g I W I Press[PC Conn]key
Character input display The printer is in the standby
state
3 From M-1Pro IV PC, open the file you want to send to the printer.

To send the existing data, open the file according to “Opening Exiting Files” (P.22).

4 Click [Send data, and Save file/Print.] in the [File] menu or click the @ button.

The Data Transfer dialog box appears.
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Set each of the items.

Send data, and Save file / Print [

Transfer Mode

@ Overwrite internal memory.;

() Add to internal memary.

File Save

[7] save transmitted data.

File name

Folder Ma.

Print

[ Print data in memary.
Frint Media Label
Media Size 9 mm

Sets to Print |1 =~ (1-10)

[ oK. l [ Cancel
[Transfer Mode]
[Overwrite internal Clears the document area in the printer, and saves the
memory.]: transmitted data at the beginning of the document area.
[Add to internal Adds the sent data at the end of the last page in the printer.
memory.]: (The printer adds new pages to the data in the printer.)
[File Save]
[Save transmitted When this option is selected, after list data is sent to the
data.]: printer, data in the printer's document area is saved under
the specified file name in the specified folder of the printer's
storage area.
If you do not select this the data will not be saved.
[File name]: Inputs the file name.
[Folder No.]: Selects the folder number (from 1-3) for saving data.
[Print]
[Print data in Select this to print data stored in the printer's memory after
memory.]: sending, according to settings you specify.
If you do not select this the data will not be printed.
[Print Media]: Selects the type of printing media.

Select either Tube, Shrink Tube, Label,
4mm 1.D. Strip, Clear Tube, Wrap Around or Terminal I.D.
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[Media Size]:

[Sets to Print]:

Click the [OK].

Format settings and data list contents are sent to the printer.

Operating M-1 Pro IV PC

Selects the size of printing media.

The sizes you can select depend on the type of printing
media used.

Tube :2.5,3.0,4.0,5.0,6.0 or 6.5mm
Shrink Tube :3.0,3.2,4.8,6.0 or 6.4mm
Label :6.0,9.0, 12.0mm

4mm 1I.D. Strip : Size not selectable.

Clear Tube :2.5,3.0,4.0,5.0,6.0 or 6.5mm

Wrap Around : Size not selectable.
Terminal I.D. :8.0, 8.5, 9.0, 9.5 or 10.0mm

Selects the number of items to be printed.
Select from 1-10.

e If there is no data when you click the [OK], “No character data” appears.
e Click the [Cancel] to cancel data transfer and close the dialog box.

« During actual printing, the printer may automatically change the settings made at
data creation according to the printing media type in order to maintain the
required print quality. Refer to “Printing with [Specify] Specified for Set Length”

(P.35).

+» To use the printer after sending data, you need to cancel the standby state (ready
for data reception) of the printer. Make sure that the printer is not receiving data,
and then press the [Cancel] key. When the character input display appears, you
can operate the printer.

PC Connect

Standby. . .

= H [ LK L

-

Press [Cancel] key H-H amm_ L M1

The printer is in the standby

state

Character input display
(The standby state has been
canceled.)
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4.4 Creating Numbering

This section describes how to incorporate numbering into the current page in the data list,
create pages for printing according to these values and add the pages to a data list.

1 Click [Numbering] in the [Edit] menu or click the H[]_ button.

The Numbering dialog box appears.

2 Set each of the items.

Mumbering

8|

Mode

Start value

End value

Decmal - ]
0 =
10 =

Padding Character [Nune

[Mode]:

[Start value],
[End value]:

[Padding
Character]:

Selects the mode of numbering.

Select from Decimal, Hexadecimal, Ato Z or a to z.
The numbering range you can select depends on the
numbering mode.

Decimal: 0 - 99 (0 - 9 for single digit)

Hexadecimal: O-FF (0 - F for single digit)

AtoZ: AtoZ

atoz: atoz

Selects the start and end values for the numbering.

Select from Decimal, Hexadecimal, Ato Z or a to z.

«» If the start value is higher than the end value, the
numbering will be in descending order.

Selects digit matching method.
Select from None, Zero, or Space.

+» The character string length is checked when creating a numbering. When it is no
longer possible to input characters, “Length exceeded. Input data exceeds set

length.” appears.
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Click the [OK].

A numbering is created in the data list using the numbering information from the
cursor page.

File(F) Edit(E) View(y) Remote(Rl Help(H)
EECIEIEEE I

Terminal 1.D. Allline
Orientation Frame SetLength e Alignment s Character Size  Character Space  Lines
Setting...
| HorHor char | MNone | Automatic ‘ Normal | Centered | off | 3 mm Norm Narrow ‘ 1line
[ selection  Page Lt Line 2nd Line 3rd Line Conti -

Press [FL] to display the help menu.

e Click the [Cancel] to quit numbering creation and close the dialog box.

+ To delete a numbering, select the page in the data list, and then select [Delete]
from the [Edit] menu.
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Operating M-1 Pro IV PC

This section describes format setting items and settings procedures.
You can set formats for individual pages, and there is also a default format used when creating

or inserting new pages.

There procedure for setting a format for an individual page is described here. The procedure for
setting the default format is the same.

« If you try to change the different page format by selecting more than one page in the data list,
the settings will revert to the unset state (become blank settings).

1 In the data list, select the page whose format you want to change, and then select
[Format Setting] — [Page Setting] from the [Edit] menu.
(To change the default format, select [Format Setting] — [Default Setting] from the

[Edit] menu.)

The Change Format or Default Setting dialog box appears.

2 Set each of the items.

-
Change Format

Orientation

Frame

Set Length

=5c)
Mane -
@ Automatic I Specify

2,00 ~| mm (2.00-150.00)

Terminal I.D. printing area MNormal

Alignment

All line centering
Character Size
Character Space
Lines

Continuous

[Orientation]:

[Frame]:

Centered

Off

’3 mm Morm

MNarrow b
1Lline -

1 = (1-100)

Selects the orientation for printing.
Select from Hor/Hor char, Vert/Vert char or Vert/Hor char.
The default at installation is [Hor/Hor char].

+» [Vert/Hor char] print is only available when there are no
characters input.

Selects the type of frame to surround the characters.
Select from None, , [ ] , | or
The default at installation is [None].

“ When the cut length is less than 6 mm, you cannot select
a frame.
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[Set Lengthl]:

[Terminal I.D.
printing area]

[Alignment]:

[All line centering]

[Character Size]:

[Character Space]:

Operating M-1 Pro IV PC

Selects the length of tube to be cut.

With [Specify] selected, you can specify a length from 2-

150mm.(input value 200-15000)

Select this to calculate the character string length from the

character size, character space, frame and lines and fit the

character string within the set length.

The default at installation is [Automatic].

+« The decimal part of the specified value is automatically
adjusted in units of 0.25 mm according to the
specifications of the printer. To confirm the set length after
the adjustment, click [OK] in step 3 to close the Change
Format dialog and see the value in [Set Length] on the
main screen.

«» When set length is set to a value less than 8.5 mm, the
specifications for printing depend on the media type. Refer
to “Printing with [Specify] Specified for Set Length” (P.35).

Select the Terminal I.D. printing area.

Select from Normal or Expansion.

The default at installation is [Normal].

+ If you select [Expansion], the printing media shall become
only the Terminal I.D.

Selects way in which characters are aligned.

Select either Centered, Left 2mm, Left 3mm, Left 4mm or

Left 5Smm.

The default at installation is [Centered].

+ If you select [Automatic] for [Set length], you cannot select
a character alignment.

“ When set length is set to a value less than 8.5 mm, the
specifications for printing depend on the media type. Refer
to “Printing with [Specify] Specified for Set Length” (P.35).

Select a way in which characters are aligned of 2 Lines or 3
Lines.

Select from On or Off.

The default at installation is [Off].

+ If you select [Automatic] for [Set length], you cannot select
[All line centering].

+ If you select [Lines] isl Line, you cannot select [All line
centering].

+» If you select [Orientation] if [Vert/Hor char], you cannot
select [All line centering].

Selects the size of the characters.

Select either 1.3mm Norm,2mm Half, 2mm Norm, 3mm Half,
3mm Norm, 6mm Half or 6mm Norm.

The default at installation is [3mm Norm].

Selects the space between characters.
Select from Narrow, Medium, or Wide.
The default at installation is [Narrow].
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[Lines]:

[Continuous]:

Click the [OK].

Operating M-1 Pro IV PC

Selects the number of lines.
Select either 1 Line,2 Lines or 3 Lines.
The default at installation is [1 Line].

«» When [Character Size] is set to [6mm Half] or [Bmm
Norm], the number of lines is automatically set to 1 line.
(You cannot change the number of lines.)

 You can select [3 Lines] only when [Character Size] is set
to [1.3mm Norm].

Selects the number of items to be printed.
Select from 1-100.

The default at installation is [1].

The set length check takes place.

e If there is a page to which the specified settings cannot be applied, a message
asking whether to apply the changes only to those pages that can be changed.

e If the settings cannot be applied to any pages, “Cannot modify.” appears.

«» During actual printing, the printer may automatically change the settings made at
data creation according to the printing media type in order to maintain the
required print quality. Refer to “Printing with [Specify] Specified for Set Length”

(P.35).
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B Printing with [Specify] specified for Set length

When set length is set to a value less than 8.5 mm and [Terminal I.D. printing area] is [Normal],
the specifications for printing are as follows:

. Specifications applied when Set length is set to a value less than
Media

8.5 mm
Terminal 1.D. You can specify a set length but you cannot select a character alignment.

You can specify a set length but you cannot select a character alignment
Label mode.

+» When characters are printed with "Half Cut On" selected, characters

may not be aligned to the center.

Tube Even if a set length is specified on the Change Format screen, actual
Shrink Tube printing is performed assuming that [Automatic] is selected.
4mm |.D. Strip (The left and right end margins are 2.0 mm or more respectively.)
Clear Tube +« The printer automatically adjusts the set length according to the printing
Wrap Around media type to maintain the required print quality.
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4.6 Remote Operation

You can print characters on the media specified from M-1 Pro IV PC or save the data in the
printer’'s document area.
To control the printer remotely, connect it to the computer in advance.

Connecting the Printer and Computer

1 Connect the printer to the computer with the USB cable.

Connect this plug to the printer.

USB cable

Insert in the USB jack on the right
side of the printer.
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Starting Printing

You can print data maintaining it in a printer.

When you print the data which you made in an application, refer to “Sending Data to the Printer”

(P.26).

1

3

Connect the printer to the computer with the USB cable.

For how to connect with the USB cable, refer to “Connecting the Printer and
Computer” (P.36).

Power the printer on. When the character input display appears, press the [PC Conn]
key on the printer.

[PC Conn] key

/
OO I I I =]

EEEEEERN

= m*ﬁm\".‘
||

[ 11

[ 1 1 ]
BN K1I54(13

PC Connect
Standby. ..

H-H sim L W1

Press [PC Conn] key

The printer is in the standby
state

Character input display

Select [Start Print] from the [Remote] menu.

The Print dialog box appears.
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5

Set each of the items.

Operating M-1 Pro IV PC

«» While M-1 Pro IV PC is running, the previous settings used are displayed as

default settings.

Print -
Print Media [Label - ]
Media Size [9 mrm "]
Sets to Print 1 = (1-10)

[Print Media]:

[Media Size]:

[Sets to Print]:

Click the [OK].

Selects the type of printing media.

Select either Tube, Shrink Tube, Label, 4mm 1.D. Strip, Clear
Tube, Wrap Around or Terminal I.D.

Selects the size of printing media.

The sizes you can select depend on the type of printing
media used.

Tube

Shrink Tube

Label

:2.5, 3.0, 4.0,5.0,6.0 or 6.5mm
:3.0, 3.2,4.8, 6.0 or 6.4mm
6.0, 9.0, 12.0mm

4mm |.D.Strip :Size not selectable.
Clear Tube

Wrap Around

Terminal I.D.

:2.5, 3.0, 4.0, 5.0, 6.0 or 6.5mm
:Size not selectable.
: 8.0, 8.5, 9.0, 9.5 0r 10.0mm

Selects the number of items to be printed.
Select from 1-10.

The data is sent to the printer

e Click the [Cancel] to cancel printing and return to the main screen.

«» During actual printing, the printer may automatically change the settings made at
data creation according to the printing media type in order to maintain the
required print quality. Refer to “Printing with [Specify] Specified for Set Length”

(P.35).
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«» To use the printer after sending data, you need to cancel the standby state (ready
for data reception) of the printer. Make sure that the printer is not receiving data,
and then press the [Cancel] key. When the character input display appears, you
can operate the printer.

PC Connect = HY» 9.9 Ul
Standby. . . #
Press [Cancel] key H-H amm_ 1 M1
The printer is in the standby Character input display
state (The standby state has been
canceled.)
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Saving Print Data

Go through the procedure for saving the character data you created using the M-1Pro IV PC in
the file in the printer.

You can save character data and the following character settings:
e Format Settings (4.5 Format Settings (P.32))

e Numbering Settings (4.4 Creating Numbering (P.30))

When you save the data which you made in an application, refer to “Sending Data to the Printer”

(P.26).

1 Connect the printer to the computer with the USB cable.

For how to connect with the USB cable, refer to “Connecting the Printer and
Computer” (P.36).

2 Power the printer on. When the character input display appears, press the [PC Conn]
key on the printer.

[PC Conn] key

|‘" LT rrrwnr|s = II\

LI LT T Iy \'
LILIL T ﬂ ﬂ m ||J l lL ﬂl ﬂ |
L 1T 1L

L T 1T HWWIWW[W?I W |

LTI [ 1 1] = |
| I, [«l¥] v]=‘

PC Gonnect

# Standby. . .

H-H ftm I W 1) Press[PC Conn] key

Character input display The printer is in the standby
state

3 Select [Save Data] from the [Remote] menu.

The Save Data dialog box appears.
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4 Set each of the items.

Save file A ﬁ

File name file1

[ Ok ] [ Cancel

[File name]: Inputs the file name.
[Folder No.]: Selects the folder number (from 1-3) for saving data.
5 Click the [OK].

The file name you specified, folder number and save command are sent to the printer.

e Click the [Cancel] to cancel data saving and return to the main screen.

+» To use the printer after sending data, you need to cancel the standby state (ready
for data reception) of the printer. Make sure that the printer is not receiving data,

and then press the [Cancel] key. When the character input display appears, you
can operate the printer.

PC Connect - Hi» ELTY
Standby. . . #
Press [Cancel] key H-H amm_ L M1
The printer is in the standby Character input display
state (The standby state has been
canceled.)
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Operating M-1 Pro IV PC

Saving the Backup Data

Save the backup data of the files stored in the printer to the computer or write backup data to
the printer.

B Saving the Backup Data to the Computer

1 Connect the printer to the computer with the USB cable.

For how to connect with the USB cable, refer to “Connecting the Printer and
Computer” (P.36).

2 Power the printer on. When the character input display appears, press the [PC Conn]
key on the printer.

[PC Conn] key
[ \
(LT Wl I T I - m II\

LI T L pd \'
I ﬂﬂﬂﬂllﬂll{ﬂlﬂ |

1
L LT 111
L1 1

1 IWWIWWjI W 1|
I\H [ 11 LI 1] Hl_ﬂL‘

PC Gonnect
# Standby. . .
H-H gmm_ I W I Press[PC Conn]key
Character input display The printer is in the standby
state
3 Open the M-1Pro IV PC, and then select [Printer data backup] from the [File] menu.

The Printer data backup dialog box appears.
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5

Operating M-1 Pro IV PC

Select [Backup from the printer], and then click [OK].

Printer data backupA ﬁ

(@) Backup from the printer:

() Recovery to the printer

[ Ok ] [ Cancel

The [Save As] dialog box appears.
Input the file name, and then click the [Save].

2= Save As - @
Save in: 3Documents - @ s el

I Name Date medified

el || backil.mk3 2011/08/04 17:41

Recent Places

Desktop

Libraries

Ay
=

Computer O m

& File name:

Do, Save as type: [M—1 Fral WFC/M=1 ProlllFC Frinter data File (+n v] [ Dancal |

[M-1Pro IV PC Printer data File (.mk3)]:
Save all files stored in the printer to the computer together.

+» The M-1Pro IV PC Printer data File (.mk3/.mdk) cannot be opened on the
computer.

Data is acquired from the printer and stored in the computer as a file with the specified
file name.
+»+ To use the printer after sending data, you need to cancel the standby state (ready
for data reception) of the printer. Make sure that the printer is not receiving data,
and then press the [Cancel] key. When the character input display appears, you
can operate the printer.

PC Connect = Ax» LEL
Standby. . . #
Press [Cancel] key H-H amm_ 1M1
The printer is in the standby Character input display
state (The standby state has been
canceled.)
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Operating M-1 Pro IV PC

B Writing the Backup Data to the Printer

1

3
4

Connect the printer to the computer with the USB cable.

For how to connect with the USB cable, refer to “Connecting the Printer and
Computer” (P.36).

Power the printer on. When the character input display appears, press the [PC Conn]
key on the printer.

[PC Conn] key

LT
I

[ T 11
LI L

|~
MR
— _

e e PC Connect
# Standby. ..
HAH g I W I Press[PC Conn]key
Character input display The printer is in the standby
state

Open the M-1Pro IV PC, and then select [Printer data backup] from the [File] menu.
The Printer data backup dialog box appears.

Select [Recovery to the printer], and then click [OK].

Printer data bECkUEA u

() Backup from the printer

@ Recovery to the printer:

[ Ok ] [ Cancel
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Operating M-1 Pro IV PC

5 The Open dialog box appears.
Select the M-1Pro IV PC Printer data File (.mk3/.mdk), and then click [Open].
& open : 5
Loskin: [ Documents - @2 2o
= MName . Date modified
i S || backil.mk3 2011/08/04 17:41 i
Recent Places
Desktop
=l
Libraries
LY
Computer < m +
Ck File name: -
. Files of type: [M—1 PralwPC./t-1PralllPC Printer data File (5 n v] [ Cancel ]
6 A message appears to ask whether all files stored in the printer are to be overwritten.
o ™
M-1ProlVPC e

I.-"' "‘-.I All saved files will be overwritten.
W' Are you sure?

[ Yes l ’ No l
[Yes]: Backup data is sent to the printer.
[No]: The data is not saved.

@ important

Do not switch off the printer and the computer while recovering the whole data. And do not
unplug the USB cable from the printer and the computer. In this case, there is the risk that the
data saved in the printer is damaged.

7 Backup data is saved in the printer.

+» To use the printer after sending data, you need to cancel the standby state (ready
for data reception) of the printer. Make sure that the printer is not receiving data,
and then press the [Cancel] key. When the character input display appears, you
can operate the printer.

PG Connect -~ fx» LN
Standby. . . #
Press [Cancel] key H-H amm_ L M1
The printer is in the standby Character input display
state (The standby state has been
canceled.)
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Select the Printer

You can operate both M-1Pro IV/ M-1Pro Il printers by using the application software.

But you cannot set the following formats in M-1Pro Il (4.5 Format Settings (P.32))
e Terminal I.D. printing area
e Allline centering

1 Connect the printer to the computer with the USB cable.

For how to connect with the USB cable, refer to “Connecting the Printer and
Computer” (P.36).

2 Power the printer on. When the character input display appears, press the [PC Conn]
key on the printer.

[PC Conn] key

OO rEG= u\W

LI LT T Iy l
LILIL T Jl ﬂ m ||J l lL ﬂl ﬂ |
L 1T 1L

L T 1T HWWIW jl W |

[ 1 [ ] \Il_ﬂL‘

[ 1 1

e PC Connect
# Standby. . .
HAH g I W I Press[PC Conn]key
Character input display The printer is in the standby
state
3 Start the application of the M-1Pro IV on the PC, and then select [Select printer] from

the [File] menu.
The select printer dialog box appears.
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Operating M-1 Pro IV PC

4 When you use M-1Pro IV, select [M-1Pro 1V].
When you use M-1Pro lll, select [M-1Pro llI].
Select printer @

Set a printer to use.

Acquire printer information after verifying the PC connection with the printer.
At the time of changing a printer to use, open this DIALOG from a menu and
setit.

Select printer [I'«1—1Pr::I\.|I A ]

The setting of the device type
(@) M-1ProIV (Terminal I.D. printing area adjustment function)

(7) M-1ProIII {Mo Terminal 1.0, printing area adjustment function)

Automatic acquisition

[ oK ] [ Cancel ]

[Select printer]  Display the installed printer driver for a Cable I.D. printer.
Set printer driver to use.
[The setting of the device type]
[Automatic acquisition]
A printer acquires information in the case of a communication wait
state and distinguish it automatically.
[M-1Pro IV (Terminal I.D. printing area adjustment function)]
Set it in M-1Pro IV.
[M-1Pro Il (No Terminal I.D. printing area adjustment function)]
Set it in M-1Pro Il

& important

Use the same printer which is selected in [Select printer] setting. If the setting is different, it will
not work correctly.

5 You can change setting when you click [OK].

+» In case the setting is changed while data is being edited, a message appears to
ask whether to save the data or not.

«» To use the printer after sending data, you need to cancel the standby state (ready
for data reception) of the printer. Make sure that the printer is not receiving data,
and then press the [Cancel] key. When the character input display appears, you
can operate the printer.

PC Connect - Hi» ELTY
Standby. . . #
Press [Cancel] key H-H amm_ L M1
The printer is in the standby Character input display
state (The standby state has been
canceled.)
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5. How to Use the Status Monitor

Use the Status Monitor to monitor the status of the printer and status of print jobs in progress.

5.1 Setting up the Status Monitor

This section describes how to start and display the Status Monitor.

« With default, Status Monitor starts automatically every time a print job starts.

1

Click the ﬁ button (Start), and select [Control Panel] — [Hardware and Sound] — [Device

and Printers] — [Printers].

¢ Windows 8
Select [Control Panel] from the Windows [Settings], and select [Control Panel] —
[Hardware and Sound] — [Device and Printers] — [Printers].

¢ Windows Vista

Click the ﬁ button (Start), and select [Control Panel] — [Hardware and Sound] —
[Printers].

¢ Windows XP
Click the [Start], and select [Printers and Faxes].

Right-click the M-1Pro IV icon, and then select [Printing Preferences...].

The Printing Preferences dialog box appears.

Click the [Status Monitor] tab.

48



Appendix

4 Set each of the items.

= M-1ProlV Printing Preferences | 25 |

Page | Graphics | Status Monitor

Status Monitor

@ Use the Status Monitor:

(71 Mot use the Status Monitor

Version...

[ K ][ Cancel H Apply

[ Status Monitor]
[Use the Status Monitor]
The Status Monitor is displayed. (This is the default setting.)
[Not use the Status Monitor]
The Status Monitor is not displayed.
[Version]
Follow this procedure to confirm the printer driver version and copyright information.
Click [Version...] to open the Version dialog box.

5 Click the [OK].

@ important

B Precautions for Making Changes to the Printing Settings Using the Printer Driver

Do not make changes to the printing settings in the Page and Graphics sheets of the Printing
Preferences dialog box of the printer driver. The changes are not reflected in the printing performed
from the M-1Pro IV PC.
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5.2 Using the Status Monitor

Use the Status Monitor to not only monitor the status of print jobs in progress but also monitor
the status of the printer and the level of the remaining ink ribbon.

Status: Printing iz ready.

Fibbaon tvpe: Black,Lone

Ribbon remaining:

[Status]
Messages to inform you about the current status of the printer.
[Ribbon type]
The ribbon cassette information is displayed.
There are 4 kinds of ribbon cassettes as follows,
Black, Long
Black, Short
White, Long
Black, Short, Plate
< “Long” or “Short” represents a "Ribbon type" not a "Remaining
quantity of the Ribbon".
[Ribbon remaining]
Rough amount of the remaining ink ribbon is displayed as shown in green.
When the information of the cassette is not properly retrieved, the amount of
the ribbon does not appear.
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Viewing the Printer Status

There are four types of images to keep you informed about the status of the printer.

B M-1Pralv touﬂlg Displayed to indicate the normal

- mode.
Status: Printing is ready. The printer is in the online mode and
Ribbon type: Black Lone ready to prin'[.
Ribbon remainine: [
B M-1ProlV (Offline) = Displayed to indicate that the printer

is in the offline mode.
Statuz: Mo connection

Ribbor type:

Ribbon remainine: |

8 M-1Pralv Mauﬂu Displayed when a warning has been

issued.
Status: Printing iz ready (Ribbon Mear End) A warning message is displayed for the
Ribbon type: Black Lone Status but printing can continue.

Troubleshoot the problem as required.

Ribbon remainine: gy

Displayed when an error has been

Brrave N
issued.

Status: Now printing.{No Media) An error message is displayed for the
Ribbon type: Black Long Status, and printing cannot be done in this

Ribbon remainine:  p— | status. Troubleshoot the problem as
required.
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Message List

Appendix

If a trouble occurs with the printer connected, an error message or a warning message is
displayed on the Status Monitor.

Message

Description

Action

No media.

An attempt was made to print while
no printing media has been loaded.

Load the print media.

End of media.

The end of the printing media was
reached while printing was in
progress.

Take out the printing media
from the printer, and replace it
with new printing media.

End of ribbon.

The end of the ribbon cassette was
reached while printing was in
progress.

Install a new ribbon cassette.

Start of media not
detect.

An operation was attempted while
the printing media was not inserted

properly.

Take out the printing media,
reinstall it correctly,

No ribbon cassette.

An attempt was made to print while
no ribbon cassette was installed.

Install a ribbon cassette.

Cutter initialization
error

It is impossible to initialize the cutter
position for some reason.

Power the printer off and on
again.If the same message
appears again, contact your
nearest dealer.

Media JAM

Tube or label tape is jammed.

Remove the jammed printing
media according to “If a Tube or
Label Tape Becomes Jammed”
in the M-1Pro IV User's Guide.

Cover is open

An operation was attempted while
the cover was open.,

Close the cover.

Feeder error.

An error occurred in the optional
tube feeder due to some cause.

Consult the User's Manual for
the tube feeder.

Head home sensor
error

It is impossible to move the print
head to the printing position for
some reason.

Power the printer off and on
again.If the same message
appears again, contact your
nearest dealer.

Head initialization
error

It is impossible to initialize the print
head position for some reason.

Power the printer off and on
again.If the same message
appears again, contact your
nearest dealer.

Ribbon near end

Remaining ribbon is low when
printing. (approximately 10m
remaining)

Have a new ribbon cassette
ready. Replace with new ribbon
cassette if printing a long
document.

USB I/O error

A communication error has
occurred.

Check connections again.
Power the computer and printer
off and on again.
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6. Appendix
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All line centering............cccoeevvvveeeeeeeeeeeecnnnnen. 33 N

B NOW et 15,16, 21

Backup Data.....ooeeeeeeeeeeieieieieieeeeeeeeeeeeeen, 42 Numbering........cccccccvvvvviiiieiiiieeiinnn, 15,17, 30

Backup from the printer.........cccccveeeiieeennn. 43 o

¢ OPEeN .o 15, 16, 22

Character S1Ze.....ccccoeeeeeeeieieieieeeeeeeeeeeeeeeennn, 33 Orientation.....cooooeiiiiiiiiiiiieeeeeeeeieeee e 32

Character Space ........ccceeevveeeerrveeeeniireeeennnes 33 P

(07) 0175010 (010 1= T 34

[070) 020 USSP 17 Padding Character ..........ccccccoovvvniiineneeennnn. 30

CSV fIlES eveeeiiieieecie et 19 Page Copy .oveveveeeniieeieiccieecee e, 15,17

ULttt 17 Page Cut....ccoovviiiiiiii 15,17

D Page Delete .......ooovvvvvevveeieeiiiiiiiiiiieiiinn, 15, 17
Page Insert.....ccccccvvvveeiiiiiiiiiiiiiiiiieeeeee, 15, 17

Data Last..eeeeeeieieee e 15 Page Paste......cccccoovvvevvviiiiiiiiiiiiiiiiii, 15, 17

Data Toolbar.......couueeeeieeeeeeiieeeeeiieeeeeeeeeeeen 18 Paste...ccooovieiii e, 17

Delete .o 17 PrINt oo 28

E Print Media......cccccvvvvvviiiiiiiiiiiiiiiiiiieen, 28, 38
Printer data backup ....cccccccoeeieeeiiiininnnninnnn. 16

Edit TooIDAT .......ciovieieeeeeeeeeeeeeeeee e, 18 Printing ... 37

Endvalue...ooooooeeiiiiiiiiiiiiieeeeeee, 30 R

EXIb i 16

7 Recovery to the printer ..........ccceevvveeeeiennn. 44
Remote .....oveeeeeiiiiiiiiieeiee, 18, 36

FE1E e e 16 Ribbon remaining.........cccceevviiviiiniiininnns 50

FLE SAVE et 28 Ribbon type ...ccccveieeeiiieieieee e, 50

File TYPES cooveeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeen 19 S

Format Setting .......coooeveeeeeeeeeieieieieeeeennn. 17, 32

Frame...coooooviieeeieee e 32 SAVE e, 15,16, 24

o SAVE AS it 16, 25
SaVe Data i 18

Help oo 18 SAVING...ccotiiiiieiiiee e 40
Select printer .........coccevvveeeeeeeeeeeinnnns 13, 16, 47

1 L. T 15,16

INSEALL. e 3 Send Toolbar.........cccovviiieiriniiiniiiiiine, 18
Sending Data .......cccoovveeeiiiiiiiiiiiieeeeeeeeein, 26

L Set Length........oveeeeeeeeeeeeeeeeeeeeeessennes 33,35

LARES. oo 34 Sets £0 PLIN ..o 29, 38

T Shutting DOWn....ccoevvvveieieieieieceeeeeeee e 13

Start Print....oooeeeeeeeeeeeeiieee et 18

53



Start value .....ccceeeeeeeciiiiiieeeccccccieeee e
Status Bar.......ccccooeeviiiiiii e,
Status Monitor ..........ooevveeveriiiiiiiiiinnns. 48,
Style Settings /Data Display Area..............
T

Terminal I.D. printing area...........cccceeeennneee
The setting of the device type................ 13,
TOO0IDAT ...ceeeiiiiieee et

‘C}O
jan)

18
50
15

& 55 68

54

Appendix

Transfer Mode .........oeeeeeiiiiiiiiiiiiieeieeeeiiiinnn, 28
U

Uninstall ...oooeiiiiiii e, 11
14

VIBW .ottt 18



	SOFTWARE LICENSE AGREEMENT
	Contents
	Introduction
	System Requirements
	1. Installing
	1.1 Installing M-1 Pro IV PC and the Printer Driver
	1.2 Uninstalling the Software

	2. Starting M-1 Pro IV PC
	2.1 Starting
	2.2 Shutting Down

	3. Screen Structure
	3.1 Main Screen
	Data List
	Toolbar
	Style Settings /Data Display Area
	Menu Bar
	Status Bar


	4. Operating M-1 Pro IV PC
	4.1 File Types
	4.2 Basic Operations
	Creating a New Data List
	Opening Existing Files
	Loading Additional Data
	Saving Data Lists

	4.3 Sending Data to the Printer
	4.4 Creating Numbering
	4.5 Format Settings
	4.6 Remote Operation
	Connecting the Printer and Computer
	Starting Printing
	Saving Print Data
	Saving the Backup Data
	Select the Printer


	5. How to Use the Status Monitor
	5.1 Setting up the Status Monitor
	5.2 Using the Status Monitor
	Viewing the Printer Status
	Message List


	6. Appendix
	6.1 Index


