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 Trademarks 
 
Microsoft, Windows and Windows Vista are registered trademarks or trademarks of Microsoft 
Corporation in the United States and/or other countries.  
 
 

 Abbreviations 
Throughout this document the following abbreviations are used in text. 
 

• Microsoft Windows Vista is abbreviated as “Windows Vista” 
• Microsoft Windows XP is abbreviated as “Windows XP” 
• Microsoft Windows 2000 is abbreviated as “Windows 2000” 

 
 

 May we request 
Thank you for understanding the following points. 
 

• Copying this guide or any part of this guide without permission is strictly forbidden. 
• The specifications for this printer as well as the software provided with the printer are 

subject to change without prior notice. 
• We strive to ensure accuracy of information in this guide, but if you notice errors or 

omissions, please contact us. 
• We can accept no responsibility for loss or damages resulting from the use of this 

software. 
 
 



 

SOFTWARE LICENSE AGREEMENT 

Note: Please read the following software license agreement (to be referred to as the 
"Agreement") carefully.  This Agreement is made between Nisca Corporation (to be referred to as 
"Nisca") and the user for use of software (to be referred to as the "Software," and to include 
manuals, printed matter and so forth in addition to this Agreement) provided with this Agreement 
by the user for the purpose of using the applicable printer made by Nisca (to be referred to as the 
"Printer").   
 
The user shall be presumed to have agreed to this Agreement either by taking an action that 
indicates "Consent" to the terms of the Agreement or by using the Software.  The user shall not 
be permitted to use the Software in the case of not agreeing with the Agreement.   
 
1. License 
(1) Nisca shall grant the user non-exclusive license to install the Software into a single computer 

and use such installed Software on such single computer at a time for the purpose of using 
the Printer. The user may not use the Software on plural computers at a time or on a network. 

(2) The user shall be permitted to make one reproduction of the Software as a backup for using 
the Software on the basis of clause (1) above. 

(3) With the exception of that stipulated in clauses (1) and (2) above, any and all of intellectual 
property rights of Nisca or licensors of Nisca, whether express or implied, shall not be 
transferred or licensed to the user by this Agreement. 

 
2. Restrictions on Use 
(1) The user shall not allow the Software to be used by a third party by sub-licensing, transfer, 

sales, distribution, lease, loan or any other method. 
(2) The user shall not be permitted to revise, modify, decompile, disassemble or perform any 

other form of reverse engineering on all or any portion of the Software. The user shall also not 
allow such actions to be taken by a third party. 

 
3. Title 

Title and ownership relating to the Software shall be retained by Nisca or a licensor of Nisca 
depending on their contents.   

 
4. Copyright Markings 

The user shall not alter, remove or delete any copyright markings of Nisca or a licensor of 
Nisca contained in the Software. 

 
5. Disclaimer and Exemption of Warranties 
(1) The Software is licensed "as is".  Nisca, affiliates of Nisca (exclude Nisca, to be referred to as 

“Affiliates”) and their agents or vendors shall not make any warranty, whether express or 
implied, including warranty of product feasibility or suitably to a specific purpose, with respect 
to the Software. 

(2) Nisca, Affiliates and their agents or vendors shall not be liable, as recognized by applicable 
laws, for any damages incurred due to the use or inability to use the Software (referring to all 
damages, including, but not limited to, lost profit and other derivative or incidental damages). 
This shall apply similarly even if Nisca, Affiliates and their agents or vendors were informed of 
the possibility of said damages. 

(3) Nisca, Affiliates and their agents or vendors shall not bear any liability regarding any and all 
disputes arising between the user and a third party caused by or related to use of the 
Software. 

 
6. Export 

The user shall not export, either directly or indirectly, all or any portion of the Software without 
obtaining the required approval from the Japanese government or related foreign governments. 
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7. Term of Agreement 
(1) This Agreement shall come into effect at the time the user has taken an action that indicates 

"Consent" to the terms of the Agreement or at the time the Software has been used, and shall 
remain in effect until terminated in accordance with clause (2) or (3) below. 

(2) The user shall be able to terminate this Agreement by discarding and erasing the Software 
and all of its reproductions. 

(3) This Agreement shall terminate immediately when the user has violated any of the terms of 
the Agreement. 

(4) If the Agreement has been terminated as result of clause (3) above, the user shall promptly 
discard or erase the Software and all of its reproductions. 

 
8. U.S. Government Restricted Rights Notice 

The Software is a "commercial item," as that term is defined at 48 C.F.R. 2.101 (Oct. 1995), 
consisting of "commercial computer software" and "commercial computer software 
documentation," as such items are used in 48 C.F.R. 12.212 (Sept. 1995).  Consistent with 48 
C.F.R. 12.212 and 48 C.F.R. 227.7202-1 through 227.7202-4 (June 1995), all U.S. 
Government End Users shall acquire the Software with only those rights set forth herein. 
Manufacturer is NISCA CORPORATION/430-1 Kobayashi, Masuho-cho, Minamikoma-gun, 
Yamanashi 400-0593, Japan.  The term "the Software" used in this clause refers to and 
indicates the "Software" defined in this Agreement. 

 
9. Separable Agreement 

In the case it has been determined that a portion of any of the terms of this Agreement 
become invalid by law, the other terms of the Agreement shall remain completely in effect.   

 
Nisca Corporation 
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Introduction 
 

Introduction 

This manual contains descriptions of operating instructions for the Application software “M-1 Pro 
III PC”. 
Please read this manual carefully to ensure correct operation. 
 
This manual has been written with the assumption that users have knowledge of basic Windows 
operations and functions. We recommend that users familiarize themselves with the Windows 
environment before using M-1 Pro III PC. For details about Windows terminology or operations 
such as ‘Open’, refer to the documentation provided with Windows. 
 

 

 Screens Appearing in This Manual 
 

• This manual provides descriptions using the screens displayed under Windows Vista. 
Basically, the screen contents and operation methods of Windows Vista are true of 
Windows XP and Windows 2000. If they are different, descriptions will be provided 
separately for individual operating systems. 

 
• Buttons displayed on the screen are enclosed in [  ].  

Example: [OK] 
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System Requirements 

System Requirements 

The hardware and software items listed below are required for using M-1 Pro III PC. 
 

 Compatible operating systems 
 
Windows Vista (English) 
Windows XP (English) 
Windows 2000 (English) 
 

 Be sure to log on as a member of Administrators when starting up. 
 

 Computer 
 
A computer that supports any of the above operating systems. 
 

 Monitor and video driver 
 
A Monitor capable of 800 x 600 dots resolution and 256 color display or higher. 
1024 x 768 recommended. 
 

 When using an 800 x 600 dot monitor, set the display font size to “Small Fonts”. 
 

 Memory 
 
At least the recommended amount of memory for the operating system. 
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Installing 

1. Installing 

1.1 Installing M-1 Pro III PC and the Printer Driver 
Install M-1 Pro III PC and the printer driver for the M-1 Pro III into your computer.  
 

 Close all applications before installing the software.  
 Be sure to log on as a member of Administrators when starting up. 
 Windows Vista/ Windows XP allows multiple users to use one computer at the same time. 
However, only one user can log on to the computer when making settings. 

 

1 Have ready the installation CD-ROM that contains the software. 

2 Turn on your computer and start Windows. 

3 Insert the CD-ROM to install the software into your CD-ROM drive. 

• If the CD-ROM does not start automatically, double-click the CD-ROM drive icon, 
and then double-click the [Run Setup.exe] file in the [APP] folder. 

• When the AutoPlay screen appears, click [Setup.exe]. 
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Installing 

• When the User Account Control dialog box appears, click the [Allow]. 

 

4 Install the M-1Pro IIIPC. 

(1) Click the [Next]. 

 

(2) Read the License Agreement, select “I accept the terms of the license agreement” 
and then click the [Next]. 
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Installing 

(3) Specify the destination for installation and then click the [Next]. 

 
 

• To install the software in the folder displayed, click the [Next]. 
• To install the software in a different folder, click the [Change] and specify a folder. 

(4) Click the [Install]. 

 

(5) Click the [Finish]. 

 
 

This completes the M-1Pro IIIPC installation. 
Next, Install the Printer Driver. 
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Installing 

5 Install the Printer Driver. 

(1) The Printers folder opens. Click the [Add a printer]. 

 
 

♦ Windows XP/ Windows 2000 

The Printers folder opens. Double-click the [Add Printer] icon. 

 
 
The Add Printer Wizard starts. Click the [Next]. 
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Installing 

(2) Select “Add a local printer”  

 
 

♦ Windows XP/ Windows 2000 

Select “Local printer”, and then click the [Next]. 

(3) Select the port that you want to use and then click the [Next]. 

 

(4) Click the [Have Disk…]. 
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Installing 

(5) Click the [Browse…]. 

 

(6) Select [DRV] folder– [M-1ProIII.inf] file on the CD-ROM, and then click the [Open]. 

 

(7) Click the [OK]. 

 
 

• Where “F:\” is the drive letter of your computer’s CD-ROM drive. 

(8) Select “M-1 Pro III” as the printer, and then click the [Next]. 
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Installing 

• The following screen only appears if a printer driver is already installed in the 
system. 
 
Select “Replace the current driver”, and then click [Next]. 

 
 

♦ Windows XP/ Windows 2000 

Select “Replace existing driver”, and then click [Next]. 

(9) Click the [Next]. 

 
 Never change the printer name. Should you change it, print data is not properly 
sent to the printer and prints fail. 
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Installing 

• If the following screen appears, perform the following operation: 
 
Click the [Continue] 

 
 

Click the “Install this driver software anyway”. 

 
 

♦ Windows XP/ Windows 2000 

Select “Do not share this printer” in the Printer Sharing screen, and then click 
[Next]. 
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Installing 

Select “No” in the Print Test Page screen, and then click [Next]. 

 

(10) Click the [Finish]. 

 
 

♦ Windows XP 
When the following screen appears, click the [Continue Anyway]. 
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Installing 

♦ Windows 2000 
When the following screen appears, click the [Yes]. 

 

(11) The M-1 Pro III icon is added to the “Printers” folder. 

 

This completes the Printer Driver installation. 

6 Restart your computer. 
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 Follow the procedure below to install the driver for the M-1 Pro III at a later time. Restart your 
computer after installing the printer driver. 

 
＜Windows Vista＞ 

Click the  button (Start), and select [Control Panel] – [Hardware and Sound] – 
[Printers]. 
Next, click the [Add a printer], and install the printer driver. 

 
＜Windows XP＞ 

Click the [Start], and select [Printers and Faxes]. 
Next, click the [Add a printer], to start the Add Printer Wizard and install the printer 
driver. 

 
＜Windows 2000＞ 

Click the [Start], and select [Settings] – [Printers]. 
Next, double-click the [Add Printer] icon, to start the Add Printer Wizard and install the 
printer driver. 

 



Installing 

1.2 Uninstalling the Software 
 
To uninstall the M-1 Pro III PC, go through the following procedure: 
 
＜Windows Vista＞ 

(1) Click the  button (Start), select [Control Panel] – [Programs], and then click 
[Uninstall a program]. 

(2) Select [M-1 Pro III PC] from the list of the programs, and then click the [Uninstall]. 
(3) When the confirmation message appears, click the [OK]. 

(When the User Account Control dialog box appears, click the [Continue].) 
 
＜Windows XP＞ 

(1) Click the [Start], and then select [Control Panel] – [Add or Remove Programs]. 
(2) Select [M-1 Pro III PC] from the list, and then click the [Remove].  
(3) When the confirmation message appears, click the [OK]. 

 
＜Windows 2000＞ 

(1) Click the [Start], select [Settings] – [Control Panel], and then double click the 
[Add/Remove Programs] icon. 

(2) Select [M-1 Pro III PC] from the list, and then click the [Change /Remove]. 
(3) When the confirmation message appears, click the [OK]. 
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Starting M-1 Pro III PC 

2. Starting M-1 Pro III PC 

2.1 Starting 
You can start M-1 Pro III PC by one of the following methods: 
 

• Double-click the M-1Pro III PC icon on the desktop. 

• Click the  button (Start), and then select [All Programs] – [M-1Pro III PC] – [M-1Pro 
III PC]. 

♦ Windows XP/ Windows 2000 
Click the [Start], and then select [All Programs] or [Programs] – [M-1Pro III PC] – 
[M-1Pro III PC]. 

 
The main screen appears when you start M-1 Pro III PC. 

 
 
For details of the main screen parts, refer to “3. Screen Structure”(P.16) below. 
 

2.2 Shutting Down 
You can shut down M-1 Pro III PC by one of the following methods: 
 

• Click [Exit] in the [File] menu. 
• Click the  button upper right of the main screen. 

 If you are editing data when you shut down M-1 Pro III PC, a message asking 
whether to save the data appears.  
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Screen Structure 

3. Screen Structure 

This section describes details of the tool buttons and menus contained in M-1 Pro III PC.  
 

3.1 Main Screen 
This appears when you start M-1 Pro III PC. 
 
 

 
 
 

f.g.1  Main screen 
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Screen Structure 

Toolbar 
 
The toolbar contains the following buttons. 
 

Tool button Description 

 

Creates a new data list.  
Does the same thing as selecting [New] from the [File] menu. 

 If you are editing data, a message asking whether to save the data 
appears. 

 

Opens an existing file or CSV file and loads the data. 
Does the same thing as selecting [Open] from the [File] menu. 

 If you are editing data, a message asking whether to save the data 
appears. 
 If you attempt to open an existing file with the old format (.mtd), a 
message may appear to indicate that it has been replaced with a file with 
the new format (.md2). 

 

Saves the data you are editing in an existing file. 
Does the same thing as selecting [Save] from the [File] menu. 

 
Sends the data you are editing to the M-1 Pro III. 
Does the same thing as selecting [Send] from the [File] menu. 

 
Sets a numbering and adds numbering data to the specified pages. 
Does the same thing as selecting [Numbering] from the [Edit] menu. 

 
Inserts a blank page in front of the cursor page. 
Does the same thing as selecting [Page Insert] from the [Edit] menu. 

 
Deletes the cursor page. 
Does the same thing as selecting [Page Delete] from the [Edit] menu. 

 
Cuts the specified page and pastes it to the clipboard. 
Does the same thing as selecting [Page Cut] from the [Edit] menu. 

 
Copies the contents of the specified page to the clipboard.  
Does the same thing as selecting [Page Copy] from the [Edit] menu. 

 

Pastes the contents of the clipboard by inserting it in front of the specified 
page. 
Does the same thing as selecting [Page Paste] from the [Edit] menu. 

 

Style Settings /Data Display Area 
 
This area displays current format settings. To change the format settings, click the 

button. 
For details about settings, refer to “4.5 Format Settings”(P.31). 
 

Data List 
 
This is a list of files currently being edited. 
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Screen Structure 

Menu Bar 
 
The Menu bar contains the following menus. 
 

 
 
 

 [File] menu 

 
 

Menu item Description 
New (N) Creates a new data list.  

There is also the  button that performs this function. 

 If you are editing data, a message asking whether to save 
the data appears. 

Open (O) Opens an existing file or CSV file and loads the data. 
There is also the  button that performs this function. 

 If you are editing data, a message asking whether to save 
the data appears. 
 If you attempt to open an existing file with the old format 
(.mtd), a message may appear to indicate that it has been 
replaced with a file with the new format (.md2). 

Add (L) Opens another file and adds the data to the data you are 
editing. 

Save (S) Saves the data you are editing in an existing file. 
There is also the  button that performs this function. 

Save As (A) Saves the data you are editing in a new file with a name that 
you assign. 

Send (P) Sends the data you are editing to the M-1 Pro III. 
There is also the  button that performs this function. 

Printer data operation (D) Saves the backup data of the files stored in the printer to the 
computer, or writes backup data to the printer. 

Exit (X) Shuts down M-1 Pro III PC. 
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Screen Structure 

 [Edit] menu 

 
 

Menu item Description 
Cut (T) Cuts the specified data and pastes it to the clipboard. 
Copy (C) Copies the selected contents to the clipboard.  
Paste (P) Pastes the contents of the clipboard. 
Delete (D) Deletes the selected part. 
Numbering (N) 
 

Sets a numbering and adds numbering data to the 
specified pages. 
There is also the  button that performs this function.

Page Cut (K) 
 

Cuts the specified page and pastes it to the clipboard. 

There is also the  button that performs this function.

Page Copy (O) 
 

Copies the contents of the specified page to the 
clipboard. 

There is also the  button that performs this function.

Page Paste (L) 
 

Pastes the contents of the clipboard by inserting it in 
front of the specified page. 

There is also the  button that performs this function.

Page Insert (I) 
 

Inserts a blank page in front of the cursor page. 
There is also the  button that performs this function.

Page Delete (R)  
 

Deletes the cursor page. 
There is also the  button that performs this function.

Page Setting (P) Changes the format settings for the cursor page. 
Format 
Setting (S) Default Setting (D) Sets the default format to be used when creating new 

data lists or inserting pages. 
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  [View] menu 

 
 

Menu item Description 
Data Toolbar (1) Shows or hides the data toolbar. 
Send Toolbar (2) Shows or hides the send toolbar. 
Edit Toolbar (3) Shows or hides the edit toolbar 
Status Bar (S) Shows or hides the status bar. 

 
 

 [Remote] menu 

 
 

Menu item Description 
Start Print (P) Sends a print command to the M-1 Pro III. 
Save Data (S) Sends a save data command to the M-1 Pro III. 

 
 

 [Help] menu 

 
 

Menu item Description 
Help                   F1 Displays M-1 Pro III PC help. 
About M-1Pro III PC (A) Displays M-1 Pro III PC version information. 

 
 

Status Bar 
 
Displays the current status of the M-1 Pro III PC. 
 



Operating M-1 Pro III PC 

4. Operating M-1 Pro III PC 

4.1 File Types 
With M-1 Pro III PC, you can load the following file types into the data list.  
 

• Original data files (.md2) 
• CSV files (Comma separated text files) 

 
To load data into the data list, files must meet the following conditions:  

1st line: First line of character data 

2nd line: Second line of character data 

3rd line: Third line of character data 

4th line: Number of continued printing 

 Data from and including the 5th line is ignored. 

 
(E.g.1) Loading CSV data into M-1 Pro III PC 
 

 
 
(E.g.2) CSV data from E.g.1 loaded into the data list.  
 

Page 1st line 2nd line 3rd line Continuous
1 A 123 456 1 
2 B 123 456 2 
3 C 123 456 3 
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Operating M-1 Pro III PC 

4.2 Basic Operations 
This section describes the methods for creating new data lists, creating data lists from existing 
data and sending data to the M-1 Pro III. 
 

Creating a New Data List 
 

1 Click [New] in the [File] menu or click the  button. 

A new data list is created. 
The format set in [Format Setting] – [Default Setting] in the [Edit] menu is used. 

 

 If you are editing data, a message asking whether to save the data appears.  

 
 

[Yes]: Saves the data you are editing and creates a new data list. 
If the file already has a name, it is overwritten. 
If the file does not have a name, the Save As dialog box appears, 
where you can give the file a name. 

[No]: Creates a new data list without saving the data you are editing. 
[Cancel]: Cancels the [New] command. 
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Operating M-1 Pro III PC 

Opening Existing Files 
 
You can load your own original data files (.md2) or CSV files into the data list.  
 

1 Click [Open] in the [File] menu or click the  button. 

The Open dialog box appears. 

 

2 Select an original data file (.md2) or CSV file, and then click the [Open]. 

The selected file is loaded and displayed in the data list. 
The format set in [Format Setting] – [Default Setting] in the [Edit] menu is used. 

 

 If you are editing data, a message asking whether to save the data appears.  

 
 

[Yes]: Saves the data you are editing and creates a new data list. 
If the file already has a name, it is overwritten. If the file does not 
have a name, the Save As dialog box appears, where you can give 
the file a name. 

[No]: Opens the selected file without saving the data you are editing. 
[Cancel]: Cancels file loading. 
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Operating M-1 Pro III PC 

  If you attempt to open an existing file with the old format (.mtd), a message may 
appear to indicate that it has been replaced with a file with the new format (.md2). 

 
 

[OK]: The file with the new format (.md2) substitutes for the existing file 
with the old format (.mtd) and then opens. 

3 When you select a CSV file, the Read Format Selection dialog box appears. 

For details about individual setting items, refer to “4.5 Format Settings”(P.31). 

 
 

 If you select [1 Line] in [Lines], the first line of data in the CSV file is loaded, but 
the second line and the third line are ignored. 

 The third line of data can be loaded only when [Character Size] is set to [1.3mm 
Norm]. 
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Operating M-1 Pro III PC 

Loading Additional Data  
 
You can add data to a specified position in the data list.  
 

1 Select the file you want to add, and then click the [Open]. 

The Open dialog box appears. 

2 Select the file you want to add, and then click the [Open]. 

The data in the selected file is added at the cursor position. 
 

Saving Data Lists 
 

 Overwriting when saving 
 

1 Click [Save] in the [File] menu or click the  button. 

The file you are editing is overwritten. 
 

 If “Untitled” appears in the title bar, the Save As dialog box appears. For details 
about saving the file, refer to “Saving a file with a new name”. 

 If you attempt to open an existing file with the old format, it is replaced with the file 
with the new format (.md2). Accordingly, selecting [Save] displays the Save As 
dialog box. The file saved in the new format cannot be opened by the old version 
of software. 
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 Saving a file with a new name 
 

1 Select [Save As] from the [File] menu. 

The Save As dialog box appears. 

2 Input the file name, specify the file type, and then click the [Save]. 
Select the file type from the following: The contents that are saved depend on the file 
type. 

[Original data files (.md2)]: Saves format settings and data list contents. 
[CSV file]: Saves the first, second and third lines of character 

data in the data list, and the numbering value. 

 
 

The data list is saved with the file name you assigned. 
 

 If a file already exists with the same name as the one you input, a message 
appears asking whether it is ok to overwrite the existing file.  

 
 

[Yes]: The file is overwritten. 
[No]: The file is not saved. 
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4.3 Sending Data to the Printer 
You can send data you create with M-1 Pro III PC to the M-1 Pro III. 
This section also describes settings for saving and printing sent data. 
Before sending data to the printer, connect the USB cable to the printer and the computer. 
 

1 Connect the USB cable to the printer and the computer. 

For how to connect the USB cable, refer to “Connecting the Printer and Computer” 
(P.34). 

2 Power the printer on. When the character input display appears, press the [PC Conn] 
key on the printer. 

 

 
 

 

3 From M-1Pro III PC, open the file you want to send to the printer. 

To send the existing data, open the file according to “Opening Exiting Files” (P.23). 

4 Click [Send] in the [File] menu or click the  button. 

The Data Transfer dialog box appears. 
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Operating M-1 Pro III PC 

5 Set each of the items. 

 
 

[Transfer Mode]  
[Overwrite internal 
memory.]: 

Clears the document area in the printer, and saves the 
transmitted data at the beginning of the document area. 

[Add to internal 
memory.]: 

Adds the sent data at the end of the last page in the printer. 
(The printer adds new pages to the data in the printer.) 

[File Save]  
[Save transmitted 
data.]: 

When this option is selected, after list data is sent to the 
printer, data in the printer’s document area is saved under 
the specified file name in the specified folder of the printer's 
storage area. 
If you do not select this the data will not be saved. 

[File name]: Inputs the file name. 
[Folder No.]: Selects the folder number (from 1-3) for saving data. 
[Print]  
[Print data in 
memory.]: 

Select this to print data stored in the printer’s memory after 
sending, according to settings you specify. 
If you do not select this the data will not be printed. 

[Print Media]: Selects the type of printing media. 
Select either Tube, Shrink Tube, Label,  
4mm I.D. Strip, Clear Tube, Wrap Around or Terminal I.D. 
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[Media Size]: Selects the size of printing media. 
The sizes you can select depend on the type of printing 
media used. 
Tube : 2.5, 3.0, 4.0, 5.0, 6.0 or 6.5mm 
Shrink Tube : 3.0, 3.2, 4.8, 6.0 or 6.4mm 
Label : 6.0, 9.0, 12.0mm 
4mm I.D. Strip : Size not selectable. 
Clear Tube : 2.5, 3.0, 4.0, 5.0, 6.0 or 6.5mm 
Wrap Around : Size not selectable. 
Terminal I.D.  : 8.0, 8.5, 9.0, 9.5 or 10.0mm 

[Sets to Print]: Selects the number of items to be printed. 
Select from 1-10. 

6 Click the [OK]. 

Format settings and data list contents are sent to the printer. 
 
• If there is no data when you click the [OK], “No character data” appears. 
• Click the [Cancel] to cancel data transfer and close the dialog box. 

 

 During actual printing, the printer may automatically change the settings made at 
data creation according to the printing media type in order to maintain the 
required print quality. Refer to “Printing with [Specify] Specified for Set Length” 
(P.33). 

 To use the printer after sending data, you need to cancel the standby state (ready 
for data reception) of the printer. Make sure that the printer is not receiving data, 
and then press the [Cancel] key. When the character input display appears, you 
can operate the printer. 
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4.4 Creating Numbering 
This section describes how to incorporate numbering into the current page in the data list, 
create pages for printing according to these values and add the pages to a data list. 
 

1 Click [Numbering] in the [Edit] menu or click the  button. 

The Numbering dialog box appears. 

2 Set each of the items. 

 
 

[Mode]: Selects the mode of numbering. 
Select from Decimal, Hexadecimal, A to Z or a to z. 
The numbering range you can select depends on the 
numbering mode. 
Decimal: 0 - 99 (0 - 9 for single digit) 
Hexadecimal: 0-FF (0 - F for single digit) 
A to Z: A to Z 
a to z: a to z 

[Start value],  
[End value]: 

Selects the start and end values for the numbering. 
Select from Decimal, Hexadecimal, A to Z or a to z. 

 If the start value is higher than the end value, the 
numbering will be in descending order. 

[Padding 
Character]: 

Selects digit matching method. 
Select from None, Zero, or Space. 

 

 The character string length is checked when creating a numbering. When it is no 
longer possible to input characters, “Length exceeded. Input data exceeds set 
length.” appears. 

3 Click the [OK]. 

A numbering is created in the data list using the numbering information from the 
cursor page. 

 
• Click the [Cancel] to quit numbering creation and close the dialog box. 

 To delete a numbering, select the page in the data list, and then select [Delete] 
from the [Edit] menu. 
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4.5 Format Settings 
This section describes format setting items and settings procedures. 
You can set formats for individual pages, and there is also a default format used when creating 
or inserting new pages. 
There procedure for setting a format for an individual page is described here. The procedure for 
setting the default format is the same. 
 

 If you try to change the different page format by selecting more than one page in the data list, 
the settings will revert to the unset state (become blank settings).  

 

1 In the data list, select the page whose format you want to change, and then select 
[Format Setting] – [Page Setting] from the [Edit] menu. 
 (To change the default format, select [Format Setting] – [Default Setting] from the 
[Edit] menu.) 

The Change Format or Default Setting dialog box appears. 

2 Set each of the items. 

 
 

[Orientation]: Selects the orientation for printing. 
Select from Hor/Hor char, Vert/Vert char or Vert/Hor char. 
The default at installation is [Hor/Hor char]. 

 [Vert/Hor char] print is only available when there are no 
characters input. 

[Frame]: Selects the type of frame to surround the characters. 
Select from None, , , ,  or 

. 
The default at installation is [None]. 

 When the cut length is less than 6 mm, you cannot select 
a frame. 
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[Set Length]: Selects the length of tube to be cut. 
With [Specify] selected, you can specify a length from 2-
150mm.(input value 200-15000) 
Select this to calculate the character string length from the 
character size, character space, frame and lines and fit the 
character string within the set length. 
The default at installation is [Automatic]. 

 The decimal part of the specified value is automatically 
adjusted in units of 0.25 mm according to the 
specifications of the printer. To confirm the set length after 
the adjustment, click [OK] in step 3 to close the Change 
Format dialog and see the value in [Set Length] on the 
main screen. 
 When set length is set to a value less than 8.5 mm, the 
specifications for printing depend on the media type. Refer 
to “Printing with [Specify] Specified for Set Length” (P.33).

[Alignment]: Selects way in which characters are aligned. 
Select either Centered, Left 2mm, Left 3mm, Left 4mm or 
Left 5mm.  
The default at installation is [Centered]. 

 If you select [Automatic] for [Set length], you cannot select 
a character alignment. 
 When set length is set to a value less than 8.5 mm, the 
specifications for printing depend on the media type. Refer 
to “Printing with [Specify] Specified for Set Length” (P.33).

[Character Size]: Selects the size of the characters. 
Select either 1.3mm Norm,2mm Half, 2mm Norm, 3mm Half, 
3mm Norm, 6mm Half or 6mm Norm.  
The default at installation is [3mm Norm]. 

[Character Space]: Selects the space between characters. 
Select from Narrow, Medium, or Wide. 
The default at installation is [Narrow]. 

[Lines]: Selects the number of lines. 
Select either 1 Line,2 Lines or 3 Lines. 
The default at installation is [1 Line]. 

 When [Character Size] is set to [6mm Half] or [6mm 
Norm], the number of lines is automatically set to 1 line. 
(You cannot change the number of lines.) 
 You can select [3 Lines] only when [Character Size] is set 
to [1.3mm Norm]. 

[Continuous]: Selects the number of items to be printed. 
Select from 1-100. 
The default at installation is [1]. 

3 Click the [OK]. 

The set length check takes place. 
 

• If there is a page to which the specified settings cannot be applied, a message 
asking whether to apply the changes only to those pages that can be changed.  

• If the settings cannot be applied to any pages, “Cannot modify.” appears. 

 During actual printing, the printer may automatically change the settings made at 
data creation according to the printing media type in order to maintain the 
required print quality. Refer to “Printing with [Specify] Specified for Set Length” 
(P.33). 
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 Printing with [Specify] specified for Set length 
 
 
When set length is set to a value less than 8.5 mm, the specifications for printing are as follows: 
 

Media Specifications applied when Set length is set to a value less than 
8.5 mm 

Terminal I.D. You can specify a set length but you cannot select a character alignment. 

Label 

You can specify a set length but you cannot select a character alignment 
mode. 

 When characters are printed with "Half Cut On" selected, characters 
may not be aligned to the center. 

Tube 
Shrink Tube 
4mm I.D. Strip 
Clear Tube 
Wrap Around 

Even if a set length is specified on the Change Format screen, actual 
printing is performed assuming that [Automatic] is selected.  
(The left and right end margins are 2.0 mm or more respectively.) 

 The printer automatically adjusts the set length according to the printing 
media type to maintain the required print quality. 
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4.6 Remote Operation 
You can print characters on the media specified from M-1 Pro III PC or save the data in the 
printer’s document area.  
To control the printer remotely, connect it to the computer in advance. 
 

Connecting the Printer and Computer 
 

1 Connect the USB cable to the printer and the computer. 

 

  

Connect this plug to the printer. 

USB cable 

 

 Insert in the USB jack on the right 
side of the printer. 
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Starting Printing 
 

1 Connect the USB cable to the printer and the computer. 

For how to connect the USB cable, refer to “Connecting the Printer and Computer” 
(P.34). 

2 Power the printer on. When the character input display appears, press the [PC Conn] 
key on the printer. 

 

 
 

 
 

3 From M-1Pro III PC, open the file you want to send to the printer. 

To send the existing data, open the file according to “Opening Exiting Files” (P.23). 

4 Select [Start Print] from the [Remote] menu. 

The Print dialog box appears. 
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5 Set each of the items. 

 While M-1 Pro III PC is running, the previous settings used are displayed as 
default settings. 

 
 

[Print Media]: Selects the type of printing media. 
Select either Tube, Shrink Tube, Label, 4mm I.D. Strip, Clear 
Tube, Wrap Around or Terminal I.D. 

[Media Size]: Selects the size of printing media. 
The sizes you can select depend on the type of printing 
media used. 
Tube :2.5, 3.0, 4.0, 5.0, 6.0 or 6.5mm 
Shrink Tube :3.0, 3.2, 4.8, 6.0 or 6.4mm 
Label :6.0, 9.0, 12.0mm 
4mm I.D.Strip :Size not selectable. 
Clear Tube :2.5, 3.0, 4.0, 5.0, 6.0 or 6.5mm 
Wrap Around :Size not selectable. 
Terminal I.D. : 8.0, 8.5, 9.0, 9.5 or 10.0mm 

[Sets to Print]: Selects the number of items to be printed. 
Select from 1-10. 

6 Click the [OK]. 

The data is sent to the printer 
 

• Click the [Cancel] to cancel printing and return to the main screen. 
 

 During actual printing, the printer may automatically change the settings made at 
data creation according to the printing media type in order to maintain the 
required print quality. Refer to “Printing with [Specify] Specified for Set Length” 
(P.33). 
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 To use the printer after sending data, you need to cancel the standby state (ready 
for data reception) of the printer. Make sure that the printer is not receiving data, 
and then press the [Cancel] key. When the character input display appears, you 
can operate the printer. 
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Saving Print Data 
 
Go through the procedure for saving the character data you created using the M-1Pro III PC in 
the file in the printer. 
 
You can save character data and the following character settings: 

• Format Settings (4.5 Format Settings (P.31)) 
• Numbering Settings (4.4 Creating Numbering (P.30)) 

 

1 Connect the USB cable to the printer and the computer. 

For how to connect the USB cable, refer to “Connecting the Printer and Computer” 
(P.34). 

2 Power the printer on. When the character input display appears, press the [PC Conn] 
key on the printer. 

 

 
 

 

3 From M-1Pro III PC, open the file you want to send to the printer. 

To send the existing data, open the file according to “Opening Exiting Files” (P.23). 

4 Select [Save Data] from the [Remote] menu. 

The Save Data dialog box appears. 
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5 Set each of the items. 

 
 

[File name]: Inputs the file name. 
[Folder No.]: Selects the folder number (from 1-3) for saving data. 

6 Click the [OK]. 

The file name you specified, folder number and save command are sent to the printer. 
 

• Click the [Cancel] to cancel data saving and return to the main screen. 
 

 To use the printer after sending data, you need to cancel the standby state (ready 
for data reception) of the printer. Make sure that the printer is not receiving data, 
and then press the [Cancel] key. When the character input display appears, you 
can operate the printer. 
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Saving the Backup Data 
 
Save the backup data of the files stored in the printer to the computer or write backup data to 
the printer. 
 

 Saving the Backup Data to the Computer 
 

1 Connect the USB cable to the printer and the computer. 

For how to connect the USB cable, refer to “Connecting the Printer and Computer” 
(P.34). 

2 Power the printer on. When the character input display appears, press the [PC Conn] 
key on the printer. 

 

 
 

 
 

3 Open the M-1Pro III PC, and then select [Printer data operation] from the [File] menu. 

The Printer data operation dialog box appears. 

4 Select [Acquire from the printer], and then click [OK]. 
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5 The [Save As] dialog box appears. 

Input the file name, and then click the [Save]. 

 
 
[M-1Pro III PC Printer data File (.mdk)]: 

Save all files stored in the printer to the computer together. 
 

 The M-1Pro III PC Printer data File (.mdk) cannot be opened on the computer. 

6 Data is acquired from the printer and stored in the computer as a file with the specified 
file name. 

 

 To use the printer after sending data, you need to cancel the standby state (ready 
for data reception) of the printer. Make sure that the printer is not receiving data, 
and then press the [Cancel] key. When the character input display appears, you 
can operate the printer. 
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 Writing the Backup Data to the Printer 

1 Connect the USB cable to the printer and the computer. 

For how to connect the USB cable, refer to “Connecting the Printer and Computer” 
(P.34). 

2 Power the printer on. When the character input display appears, press the [PC Conn] 
key on the printer. 

 

 
 

 
 

3 Open the M-1Pro III PC, and then select [Printer data operation] from the [File] menu. 

The Printer data operation dialog box appears. 

4 Select [Write to the printer], and then click [OK]. 
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5 The Open dialog box appears. 

Select the M-1Pro III PC Printer data File (.mdk), and then click [Open]. 
 

 

6 A message appears to ask whether all files stored in the printer are to be overwritten. 

 
 

[Yes]: Backup data is sent to the printer. 
[No]: The data is not saved. 

7 Backup data is saved in the printer. 

 

 To use the printer after sending data, you need to cancel the standby state (ready 
for data reception) of the printer. Make sure that the printer is not receiving data, 
and then press the [Cancel] key. When the character input display appears, you 
can operate the printer. 
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5. How to Use the Status Monitor 

Use the Status Monitor to monitor the status of the printer and status of print jobs in progress. 
 

5.1 Setting up the Status Monitor 
This section describes how to start and display the Status Monitor. 
 

 With default, Status Monitor starts automatically every time a print job starts. 
 

1 Click the  button (Start), and select [Control Panel] – [Hardware and Sound] – [Printers]. 

♦ Windows XP 
Click the [Start], and select [Printers and Faxes]. 

♦ Windows 2000 
Click the [Start], and select [Settings] – [Printers]. 

2 Right-click the M-1Pro III icon, and then select [Printing Preferences…]. 

The Printing Preferences dialog box appears. 

3 Click the [Status Monitor] tab. 

4 Set each of the items. 

 
 

［Status Monitor］ 
［Use the Status Monitor］： 

The Status Monitor is displayed. (This is the default setting.) 
［Not use the Status Monitor］： 

The Status Monitor is not displayed. 
［Window Option］ 
［Display While printing］： 

The Status Monitor automatically starts and displays when a print job starts. 
Other windows are minimized. (This is the default setting.) 
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［Display if an error occurs］： 
The Status Monitor automatically starts and displays when an error occurs. 
Other windows are minimized. (This is the default setting.) 

［Display always］： 
The Status Monitor is held active, that is, it is always displayed while printing is in 
progress or even when no error is detected. 

［Display in foreground］： 
Always display the open Status Monitor window in the foreground even when the 
windows of other software applications are open. 

［Version］： 
Follow this procedure to confirm the printer driver version and copyright information. 
Click [Version…] to open the Version dialog box. 

5 Click the [OK]. 

 
 Precautions for Making Changes to the Printing Settings Using the Printer Driver 

 
Do not make changes to the printing settings in the Page and Graphics sheets of the Printing 
Preferences dialog box of the printer driver. The changes are not reflected in the printing performed 
from the M-1Pro III PC. 
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5.2 Using the Status Monitor 
 
Use the Status Monitor to not only monitor the status of print jobs in progress but also monitor 
the status of the printer and the level of the remaining ink ribbon. 
 

 
 

［Status］： 
Messages to inform you about the current status of the printer. 

［Ribbon information］： 
Display the ribbon cassette information. 

［Ribbon remaining］： 
Rough amount of the remaining ink ribbon is displayed as shown. When the 
information of the cassette is not properly retrieved, the amount of the ribbon 
does not appear. 
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Viewing the Printer Status 
 
There are four types of images to keep you informed about the status of the printer. 
 
 

 

Displayed to indicate the normal 
mode. 
The printer is in the online mode and 
ready to print. 

 
 

 

Displayed to indicate that the printer 
is in the offline mode. 

 
 

 

Displayed when a warning has been 
issued. 
A warning message is displayed for the 
Status but printing can continue. 
Troubleshoot the problem as required. 

 
 

 

Displayed when an error has been 
issued. 
An error message is displayed for the 
Status, and printing cannot be done in this 
status. Troubleshoot the problem as 
required. 
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Message List 
 
If a trouble occurs with the printer connected, an error message or a warning message is 
displayed on the Status Monitor. 
 

Message Description Action 
No media. An attempt was made to print while 

no printing media has been loaded.
Load the print media. 

End of media. The end of the printing media was 
reached while printing was in 
progress. 

Take out the printing media 
from the printer, and replace it 
with new printing media. 

End of ribbon. The end of the ribbon cassette was 
reached while printing was in 
progress. 

Install a new ribbon cassette. 

Start of media not 
detect. 

An operation was attempted while 
the printing media was not inserted 
properly. 

Take out the printing media, 
reinstall it correctly, 

No ribbon cassette. An attempt was made to print while 
no ribbon cassette was installed. 

Install a ribbon cassette. 

Cutter initialization 
error 

It is impossible to initialize the cutter 
position for some reason. 

Power the printer off and on 
again.If the same message 
appears again, contact your 
nearest dealer. 

Media JAM Tube or label tape is jammed. Remove the jammed printing 
media according to “If a Tube or 
Label Tape Becomes Jammed” 
in the M-1Pro III User's Guide. 

Cover is open An operation was attempted while 
the cover was open.。 

Close the cover. 

Feeder error. An error occurred in the optional 
tube feeder due to some cause. 

Consult the User's Manual for 
the tube feeder. 

Head home sensor 
error 

It is impossible to move the print 
head to the printing position for 
some reason. 

Power the printer off and on 
again.If the same message 
appears again, contact your 
nearest dealer. 

Head initialization 
error 

It is impossible to initialize the print 
head position for some reason. 

Power the printer off and on 
again.If the same message 
appears again, contact your 
nearest dealer. 

Ribbon near end Remaining ribbon is low when 
printing. (approximately 10m 
remaining) 

Have a new ribbon cassette 
ready. Replace with new ribbon 
cassette if printing a long 
document. 

USB I/O error A communication error has 
occurred. 

Check connections again. 
Power the computer and printer 
off and on again. 
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